PDA

View Full Version : Fader Range / Travel



thebrokendoor
09-13-2010, 03:49 PM
Hello,


In Ableton I'm struggling to get the faders in TouchOsc to sync with the track faders in Live.


The fader seems to sometimes move in contrary motion (down is up etc) and sometimes seems to jump to the extremes of travel.


Osculator is seeing the fader travel through the full range (as observed in 'Quick Look') but I'm struggling to set it up correctly.


Many thanks,


Dan

thebrokendoor
09-13-2010, 04:13 PM
I may have just noticed that a number of controllers (XY, Rotary, Faders) are exhibiting this behaviour.


It appears the range of the controller may be too great for the item it is controlling. Could this be the case and if so, what can I do to rectify this?


Thanks,


Dan

camille
09-13-2010, 05:15 PM
Hi Dan,


You can change the range of the message values, by switching to the Scalings Page and editing the range values. This command is located in the Edit menu.

The philosophy is this one:

- set the input min / max to what you KNOW from the input range.

- set the output min max to what you WANT for the output range.

- if the Cap checkbox, the input will be "capped" to the specified input min/max range, i.e. Inout messages will be dropped if the value falls outside the specified range.


Best,

Cam


Best,

Cam

thebrokendoor
09-13-2010, 08:58 PM
Thanks Cam,


So if in 'TouchOSC Editor' I set the fader range from 0 to 1, that should be the input range in 'Osculator' but the output should be 0 to 127?


I'll experiment tomorrow but some experience would make the process easier.


Thanks for a great product!!

camille
09-13-2010, 10:24 PM
If you use a MIDI CC event, the output range will be automatically scaled to 0 127.

Actually, for a fader with a default range of 0.0-1.0, you don't need to do anything special.

thebrokendoor
09-14-2010, 09:16 AM
So at the moment I have:


TouchOSC Range 0.0 - 1.0

Osculator Input range 0.0 - 1.0

Osculator Output range 0.0 - 1.0


But I'm having this perculiar behaviour. Which Value should I be looking at changing? Your first post suggests I should change something but your second post seems to suggest that the current values are correct.


Thanks Cam, I realise you probably get a lot of this!


Dan

thebrokendoor
09-14-2010, 03:32 PM
I got it working! I read a previous post about fader values that recommended I delete the routing and start again. I'm sure I did this previously but today, voila!


Merci beaucoup Camille!

camille
09-14-2010, 05:49 PM
Great!