PDA

View Full Version : Sending MIDI CC



CV-Gate
09-30-2010, 05:42 PM
Hello forum, I'm very new on this, just bought a license yesterday. So please, excuse me if this question is already explained. I did a search and didn't find any result.


I'm trying to send MIDI CC from Osculator and I'm assigning MIDI CC to Event Type and selecting the controller number. However this doesn't work, the device receiving midi shows only values of 0 or 164. I have been checking some templates and I could see that the CC values are shown like cc0, cc1, cc10, etc... instead of just the number. I still couldn't assign that kind of values. Any help?


Thanks in advance and regards.

camille
09-30-2010, 08:20 PM
Hi CV-Gate,


Actually the names cc0, cc1, are from older versions, but the result should be the same, it's just a matter of naming.

I believe you are doing the right thing, sending MIDI CC should be rather straightforward.


I find it strange that your device shows a value of 164, because this is not a valid CC value. The value should only be given between 0 and 127.


Have you checked the OSC value that you are sending to OSCulator. I would guess that it is not normalized between 0.0 and 1.0, therefore when the value is multiplied by 127 before being fed to the MIDI output, which would explain why you only get extreme values.


To check the input on a message, the simplest way is to display a Quick Look window by pressing the Space bar on the desired message. Then send the OSC message, and check the value.


I hope it helps …


Best,

Cam

CV-Gate
10-05-2010, 10:37 AM
Hi Camille, thanks a lot for your answer. You were right. I was sending 0 to 127 values from TouchOsc instead of 0-1. Now it's working fine. Do you think to implement MSB-LSB and sysex in a future?


Regards!

camille
10-05-2010, 11:00 AM
Hi CV,


Yes, sysex and complex MIDI messages are part of a bigger work I am currently undertaking.

However, during the next weeks I will be focusing on documentation and bug fixes / improvements.


Best,

Cam