PDA

View Full Version : In. min/In. max/Cap/Out. min/Out. max



photonal
04-13-2011, 08:46 PM
Hi,

I'm trying to get data from a Quartz Composer comp into Kyma via OSCulator, however along the way I am trying to scale the values in the Scaling window but I cannot seem to get the results I want.

E.g. I would like to send values of -5 through to +5 to Kyma.

I have set :

In. min = -5.0
In. max = 5.0
Cap is unchecked
Out. min = -1.0
Out. max = 1.0

However, for example, a value of +2.10 into OSCulator is coming out as -0.16 into Kyma.

Another example, a value of +1.99 into OSCulator is coming out as -0.204 into Kyma.

So it looks like a scaling issue.

Any ideas what the problem might be?

btw, I am trying to send the value into Kyma via a Kyma Ext, WiiPitch value.

photonal
04-13-2011, 09:03 PM
I've just tried the following:

In. min = -10.0
In. max = 10.0
Cap is unchecked
Out. min = -10.0
Out. max = 10.0

Using quickview I can see that a value of +2.63 is coming into OSCulator but is arriving in Kyma as 4.26.

or for example, +2.44 is coming into OSCulator but arriving in Kyma as 3.88.

or another, +2.31 arriving in Kyma as 3.62.

and +2.21 arriving as 3.42 in Kyma.

Seems like the decimal part is being doubled but not sure what happening with the whole part.

photonal
04-13-2011, 09:16 PM
Interestingly if I do the following:

In. min = -10.0
In. max = 10.0
Cap is unchecked
Out. min = 0.0
Out. max = 10.0

Then +2.36 into OSCulator arrives as 11.36 in Kyma.
and
+2.51 into OSCulator arrives as 11.51 in Kyma.

I guess the question is, what scaling do I need to ensure that +2.51 arrives as 2.51 in Kyma (I would want a corresponding value of -2.51 to arrive in Kyma as -2.51)?

camille
04-13-2011, 11:09 PM
Hi Photonal,

This actually easy once you grasp the logic:

- input min and max must describe the input range, in a word, what range the input signal has.
- output min and output max describe what you want as the output range.

Therefore, if you signal has an input range of [0.0 1.0], you set input min and max to 0.0 and 1.0 resp. I understand you want an output of [-5.0 5.0] so you set output min to -5.0 and the max to 5.0 respectively.

You can open the Quick Look window to monitor the range of you input signal. Please note that this graph is calibrated using the input min and max range, that is, the low bound will always be input min and the upper bound input max. The values displayed are scaled to output min / max, so the numerical value you see in the monitor is corresponding to the actual output.

I hope it helps.

Best,
Cam

photonal
04-14-2011, 11:51 AM
Thanks for the tips, but I am still having issues getting data into Kyma.

I have also tried without changing the default scaling, i.e. :

In. min = 0.0
In. max = 1.0
Cap is unchecked
Out. min = 0.0
Out. max = 1.0

QuickLook is showing the data is arriving in OSCulator correct, however the data is arriving in Kyma incorrect.

e.g. +3.73 arrives in Kyma as 6.46
or
+336.13 arrives in Kyma as 671.3

Perhaps the issue is with Kyma or there any other scaling happening within OSCulator before the data is sent out?

Actually, it might be useful if the QuickLook could show graphs for the Input data and the transformed Output data.

camille
04-14-2011, 12:06 PM
It looks like the values are multiplied by 2, strange. As long as the input min / max and output min / max are the same, there is no transformation, so I guess there must be an issue somewhere else.

Also, Quick Look shows you the correct graphs: the graph is scaled with respect to the transformed output.

photonal
04-14-2011, 07:08 PM
Further to this issue I have put together this small test which highlights the problem. I have a QuartzComposer comp (ValueTestOSC) outputing data via OSCulator (ValueTest) feeding into Kyma (ValueTest.kym).The values hitting Kyma should be alternating -0.5 and 0.5, however Kyma shows values alternating from -2.0 and 0.0.
Anyone have an idea where the problem might lie?
Thanks in advance!


Files: http://www.micronaut.co.uk/photonal/files/ValueTest.zip

camille
04-14-2011, 07:18 PM
Hey Photonal,

I know what the issue is:
You are using a special controller called !WiiRoll.
You might want to check your Global Map, I am pretty sure that this controller is automatically mapped to a new range in Kyma.

Or you can also try with a more conventional control number that is not in your Globlal Map.

I am about 99.9% sure that there is no scaling in OSCulator with respect to the Kyma driver.


Best,
Cam

photonal
04-14-2011, 08:26 PM
Thanks Cam for the tip - I tried using a Continuous Controller and all is well!

Thanks a lot!!

Strange thing is though, I don't have !WiiRoll in my Global Map