PDA

View Full Version : Newbie to OSCULATOR



reubenk
01-24-2012, 11:02 PM
Hi guys, I recently got OSCULATOR going for my iPad 2 to use along with Traktor Pro 2, and I have some questions if you would be so kind to help me out.

1) Is it possible to get iPad to react to buttons I touch manually on macbook? eg. If I press the play button on traktor via macbook, the play button on the ipad that I have set also lights up.

2) I am using OSCUlator, If I leave it for a few minutes or even when I dont.. It when I click a control again it seems to take a while to 'pickup' the MIDI again.. almost like it lost the connection and needed to find it again or something ? (Im using ad-hoc with ipad + macbook).

3. I have an X-Y pad that I want to use for a filter control.. Is it hard to setup for the filter rotary button to the X-Y pad?

Thanks guys!
R

camille
01-24-2012, 11:57 PM
Hello reubenk,

1. In Traktor you define a set of mappings that map MIDI input with Traktor controls (buttons, knobs, etc.). Say for example that you have MIDI Control Change 10 that controls a filter (In mapping). If you want to be able to control back your iPad, you will need to define another mapping (Out mapping) that has the same MIDI CC (10) but in the other direction. When you touch the filter in Traktor, OSCulator will automatically map the MIDI back to your iPad because it knows that MIDI CC 10 is used by a control on your iPad. See the attached image for an example.
177

2. I am not sure this issue comes from OSCulator, however your network configuration sounds ok to me. To be sure, open a Quick Look window on the message you are interested in (select it in the main window and press the Space bar) and see if the signal reacts immediately or not. It might be possible that the iPad's wifi uses an energy saving scheme that lowers the reactivity of network operations after a while of inactivity.

3. It should be easy to map it. In OSCulator map two different MIDI CC that you don't use for something else, and in Traktor add two In mappings with those MIDI CC and mapped to the controls you would like. Depending on the orientation of your device, you might need to reverse the values of the Y axis. For this, select the argument that is inverted (/1/xy1 [0] or [1], again depending on the orientation) and press Command-I. This will invert the output values for this message by changing its scalings. (have a look at the Scalings Page, page 13 in the manual (http://dl.osculator.net/doc/OSCulator+2.11+Manual.pdf) for more info)

Let me know if you have any further question.


Best,
Cam

reubenk
01-25-2012, 02:57 PM
Hi Camille - Thanks alot for your help - I really appreciate it!
So I started with the first question.. I tried what you said about creating an 'out' mapping.. (CH16.CC.008 IN AND OUT).. In this instance it is a Play/Pause toggle button.. I have successfully created an Out Assignment and set it up to the same CC as the IN assignment, but nothing happens when I click it on Traktor. It seems in the Mapping Details it wont let me change the 'Type of controller', and is stuck on LED.. The other is set up to Toggle I wonder does this have anything to do with the problem?

Thanks mate! Will try the other solutions now also :-)

camille
01-25-2012, 03:24 PM
Hi !

99% of the time, the solution to back-mapping problems is simply to delete all the /midi/ccXX/YY messages in OSCulator, and let it recreate the correct mapping next time it receives a message from Traktor.

I just tried, and as expected when the Out mapping has been created, Traktor sent to OSCulator a message that I had not yet mapped. After I deleted the /midi/cc08/1 message, everything worked.

The LED controller type is not a problem, you can leave it as-is.


Cam

reubenk
01-25-2012, 04:06 PM
Im sorry to be a pain but I dont fully understand what you mean.
With say my play button.. I have the following flashing green in OSCulator when I press the button:
/2/play3 (hooked up to CC09)
/2/play3/z (Hooked up to CCO8)

Which do I delete? I deleted /2/play3 and I just had to remap naturally.. I deleted /2/play3/z and nothing happened ?

Thanks again
R

camille
01-25-2012, 04:28 PM
No problem, I meant to delete the messages starting with "/midi".
You want to think with the other direction in mind : form Traktor to your iPad.

reubenk
01-25-2012, 04:35 PM
None of my messages start with /midi, and im unsure what to delete? Im really confused with this :-(

So frustrating that it wont work!

camille
01-25-2012, 04:39 PM
It seems OSCulator does not receive MIDI from Traktor.
In Traktor you could check In-Port and Out-Port to see if they are correctly assigned to "OSCulator Out" and "OSCulator In (8000)"

reubenk
01-25-2012, 04:42 PM
In-Port only has options OSCulator Out - All Ports - Traktor Virtual Input.. Out-Port has OSCULATOR IN (8001) duplicated 15 times down the list ?! Looks like my in/out ports are mixed the wrong way around ?

camille
01-25-2012, 04:45 PM
I confirm:
In-Port should be "OSCulator Out"
Out-Port should be "OSCulator In (8000)"

What version of Traktor are you using?

reubenk
01-25-2012, 04:47 PM
yep that is correct, i am using 2.0.1 traktor pro

reubenk
01-25-2012, 04:56 PM
Actually, jsut when i fiddled with the out / in settings /midi/cc8/16 came up on osculator.. its value looks like D - /2/play3 .. Play3 is the button I am trying to hook up to interact with the ipad when i touch in in Traktor.. Should I delete that midi file now?

camille
01-25-2012, 05:01 PM
yep that is correct, i am using 2.0.1 traktor pro

This one works fine for me.



Actually, jsut when i fiddled with the out / in settings /midi/cc8/16 came up on osculator.. its value looks like D - /2/play3 .. Play3 is the button I am trying to hook up to interact with the ipad when i touch in in Traktor.. Should I delete that midi file now?

It sounds like it is the correct setting, why would you do that?

reubenk
01-25-2012, 05:03 PM
Sorry not midi file, but the /midi mapping.. I thought you said to delete it and let it map it itself next time I press the play button on traktor? Alas, I tried that by pressing play on traktor, the midi mapping created itself again but it didnt light up the play button on the iPad

camille
01-25-2012, 05:17 PM
There is no risk of deleting it, I said that you must delete the "/midi" message if you think it is not assigned correctly.
Now that you have MIDI In and Out, let's start from the beginning and explain exactly what you need so I can give you step by step instructions.

reubenk
01-25-2012, 06:57 PM
Ok perfect. So I have say.. a Play button, mapped on Traktor - I have it successfully setup to the play assignment on Traktor, but I want to have it so, for example if I press play on Traktor not the iPad - The iPad will also react to Traktor settings.
Thanks!
R

camille
01-25-2012, 07:19 PM
OK, here's how I would do (I used the Beatmachine layout in TouchOSC to illustrate the example):

In OSCulator, assign a MIDI CC 10 event to the message /1/push7.
In Traktor add a In mapping "Transport -> Play/Pause".
Click on "Learn" and press the button in TouchOSC.
Click again on "Learn" to turn off learning mode.
Change Interaction to Toggle.
Now, add a Out mapping, again, "Transport -> Play/Pause".
You have to configure it manually this time (remember: MIDI CC 10)
That's all folks.
Please have a look at the oscd and tsi files.
And the obligatory screenshot:

187

reubenk
01-25-2012, 08:14 PM
Hi Camille - I followed every step above but yet it still will not work. It works from ipad to traktor - but the button wont display movement when i go from traktor - ipad !

camille
01-25-2012, 08:19 PM
I'm sorry, I have absolutely no idea why it is not working.
A last thing: check that you iPad well recognized as the default OSC target like this (in the Parameters Window):
188

reubenk
01-25-2012, 10:32 PM
Yes it seems to be OK that end, I really dont know why this wont work. I keep following all the steps but still doesnt seem to work for some reason :--(

camille
01-26-2012, 01:37 AM
Ahhh, that's too bad.
Please send me your oscd file, TouchOSC layout and TSI file (export Traktor's mappings) to camille at osculator dot net and I'll have a proper look. Thanks!

reubenk
01-26-2012, 02:24 PM
Done, thank you!

camille
01-26-2012, 07:31 PM
Got it !

You control the Play/Pause Traktor widget using MIDI CC 8/16 from the message /2/play3/z.
Therfore, OSCulator synchronizes back the received MIDI CC 8/16 back to the iPad with the message /2/play3/z. This is wrong, since the /.../z messages are not assignable.

The solution is:
1. change the Play/Pause state from the button's state (/2/play3, not /2/play3/z).
2. use a push button instead of a toggle, I don't believe it is needed, since the Play/Pause state is transmitted back to the iPad when Traktor starts playing or pauses the deck.


Best,
Cam

reubenk
01-27-2012, 06:39 PM
Hi Cam, Sadly and frustratingly this is not still working - i am on the verge of giving up on it

I changed the midi mapping in Play/Pause (both in and out mappings) to MIDI CC 007 (/2/play3) rather than MIDI CC 008 (/2/play3/z).. /midi/cc7/16 now is set to /2/play3 rather than /2/play3/z as before..
I changed the button interaction mode from toggle to hold (also tried direct)
Play/Pause OUT is now set to 007 also

Yet still not a blip from the iPad when I click the Play/Pause button on Traktor.

:------(

reubenk
01-27-2012, 06:52 PM
Id also like to add, when I press play, midi/cc7/16 in osculator lights up in red, so it seems to know its getting a somewhere?

camille
01-27-2012, 06:54 PM
Reuben, I'm really sorry but I can certify the solution above works. Is there a particular reason why you change the interaction mode in Traktor?
Do you want me to send you back the version that works?

Again sorry, I wished it was easier to explain.
This is normally easy to setup.

camille
01-27-2012, 06:58 PM
Id also like to add, when I press play, midi/cc7/16 in osculator lights up in red, so it seems to know its getting a somewhere?

That means that OSCulator is not able to find your iPad on the network. This is usually related to a temporary problem with Bonjour (the automatic network configuration system) that is easily solved by rebooting the iPd and / or the computer. It can also originate from a bad WiFi router, but you said you were using an ad-hoc connection.

I am sure you are close to the solution.

reubenk
01-27-2012, 07:05 PM
Hi Camille, that would be great if you could send me the version that works for me to test!
Thanks
Reuben

reubenk
01-27-2012, 07:17 PM
Ok so I got in the green by changing the host:port on OSC routing, it seemed to be selecting the wrong one.
So the midi/cc7/16 ligts up green aswell as /2/push3 in osculator when I press Play on Traktor, but yet iPad does not light up the play button / stop to indicate if it is playing or stopped

camille
01-27-2012, 07:21 PM
You should not need to change the host / port configuration, only the Default Target.
Do you have many devices on the network that publish a OSC service?

reubenk
01-27-2012, 07:33 PM
No, just ipad

It was set to (TouchOSC), I changed it to (OSCULATOR) and it seemed to work then in terms of going green again rather than red

camille
01-27-2012, 07:35 PM
That is not correct.
The OSC Routing goes from OSCulator to TouchOSC, therefore it was correctly set to TouchOSC.
Even though the light goes green, you are creating an infinite loop.

reubenk
01-27-2012, 07:41 PM
Ok so i changed back and its back to normal again, it shines up in green this time though, but no interaction with iPad

reubenk
01-27-2012, 07:45 PM
Camille, I was thinking - Would it be better for me to send you my .tsi / osc file etc for you to have a look, then you can send back the correct version? Im beginning to think maybe it is a problem to do with network or some setting?

camille
01-27-2012, 07:46 PM
OK!

So I think I understand why it worked for me and not for you:
For some reason your TouchOSC template contained two pages with the same name. First page is named "2" and second page is "2" as well. It seems to confuse TouchOSC when automatic OSC address is enabled. Also, I found some control with weird names like "/2/play3", which is not an automatic naming, it should be "2/toggle3" or something, but anyways.

Here is the fixed TouchOSC layout (fixed page names), TSI file (changed interaction mode fron Toggle to Direct since you are using a Toggle button in your layout, if it was a push button which I recommend, it should have been the default value, namely Toggle), and the fixed OSCulator file that does not use the /z message to change the state of the button.

Edit: I forgot to mention that the first time I tried your layout, I must have been lucky regarding the page name issue. For me, this is a bug in TouchOSC that it should properly route message to controls regardless of the selected page...

reubenk
01-27-2012, 08:09 PM
Camille! It works! You are a genius!
When I replicated your settings and changed the page number it seemed to work! Thank you so much!

Now one last question before I stop annoying you finally hehe.. If I press play on traktor or even via ipad, it launches as commanded, but sometimes there is a delay in the time it takes to respond to the command. this is generally only happening when i press play on traktor and I want it to show up on ipad.. sometimes when I hit stop on traktor it takes an extra 2/3 seconds to click off on ipad.. No biggie, just thought maybe you would know - maybe its a network thing?

camille
01-27-2012, 08:19 PM
I know there is a bit of delay, but on my side it is almost instantaneous.
I don't know what could be causing this appart as you said from a networking problem.
When you see some delay, is the iPad connected with an ad-hoc (computer to computer) WiFi network?

reubenk
01-27-2012, 08:23 PM
yeah i only use ad-hoc for my connection.. its strange as 8 times out of 10 it would be fine but then there would be some delay.. usually after 2 or 3 seconds it will kick in? I think it is a connection problem my end though as i just tried again and it worked every attempt.. Anyway thanks again Camille!
Reuben