PDA

View Full Version : Getting Feedback from a knob on LEMUR



OoGuN
03-05-2012, 05:15 AM
Hi Camille and everyone else,

brilliant app, have used it for years with TouchOsc and traktor...

recently creating a template for Mixbus on the iPad Lemur app and having a problem with getting feedback to the Lemur when I move a knob in Mixbus. Going from Lemur to Mixbus works great (better than the Lemur Daemon!) and after doing a little digging and reading Osculator manual (thanks for the new accessible pdf!) I can get faders to work , i.e. if I move a fader in Mixbus, it moves the corresponding fader on Lemur. I'm achieving this with a midicc message that is set to event type OSC Routing and for a while I couldn't get fader feedback to work. Then I managed it somehow and noticed that the argument sent in the OSC Routing page is f (not "f") and this is when the feedback works. I don't know how I managed to get that as an argument, if I try typing it in, it appears as "f" and doesn't work. The f has a drop down menu triangle and shows a tick next to Float.

I'm now working on the knobs andy again I have Lemur controlling the knobs fine and I can see the midicc light flashing in Osculator when I turn a knob in Mixbus, but again no feedback. I don't know what the argument should be for knobs to work, I tried editing a copy of the fader one so I could have f as an argument but this doesn't work. If I leave the token as allargs, it doesn't work either

A lot of what I've learnt has been by jumping between TouchOsc, Osculator and Lemur, but I'm stuck at this point. What argument do I need to have for knobs and how do I enter it without ""? Thanks!

camille
03-05-2012, 09:13 AM
Hi OoGuN,


I'm achieving this with a midicc message that is set to event type OSC Routing and for a while I couldn't get fader feedback to work. Then I managed it somehow and noticed that the argument sent in the OSC Routing page is f (not "f") and this is when the feedback works.

So that would mean the Lemur app is expecting integer number insteand of floating point numbers? That sounds a bit weird, maybe a scaling issue?

The thing I don't really understand is that if you assign a OSC Routing to a MIDI CC with everything set by default (except the rewrite address), you don't need to change the argument list for that routing, is there a particular reason why you want to change it? Here's the reason why: the /midi/ccXX message you receive has only one argument. A OSC Routing, by default, is creating OSC message that have the same arguments as the input message, hence in the case of a MIDI CC, one argument. So there's no need to change the arguments token list. Also, this argument is automatically scaled from [0 127] to [0.0 1.0] (being the default range for the Lemur).

Last but not least, he he, when you send a MIDI CC messsage from an OSC device and get a MIDI feedback for that same MIDI CC, OSCulator automatically creates the needed OSC Routings back to the origin. So again, there is no need to configure anything: in this simple case, all is done for you. What I am trying to understand is why this configuration was actually needed.


I'm now working on the knobs andy again I have Lemur controlling the knobs fine and I can see the midicc light flashing in Osculator when I turn a knob in Mixbus, but again no feedback. I don't know what the argument should be for knobs to work, I tried editing a copy of the fader one so I could have f as an argument but this doesn't work. If I leave the token as allargs, it doesn't work either

Isn't Mixbus based on Ardour? If yes, I'll give a try on my side. Or use the free demo.
I'd appreciate you send me (camille at osculator net) your Lemur layout so I can write the correct recipe and give it to you.


Best,
Cam

OoGuN
03-05-2012, 11:31 AM
Thanks Camille,

Always really impressed with how helpful you are. I'm learning to create layouts at the same time as hooking them up, so I wouldn't be surprised if I've done something silly. Yes Mixbus is based on Ardour and I've sent you my layout. The layout includes faders on screen 1, which work both ways and a big knob and a switch(custom button) on screen 2 which I was using for testing and will remove when the layout is finished.

I had no feedback from the switch either.

cheers

Kola

camille
03-06-2012, 11:17 PM
Hi Kola,

After fighting with Ardour to find how to map a control to a MIDI CC, I finally found the solution.

Forenote

First of all for users that are not used to Ardour, you need a mouse with a middle button to map a control with MIDI.


Ardour Configuration

Launch Ardour (or Mixbus) and setup MIDI this way :
214

Notice that the control MIDI port is used for "control" (which is not the case by default).
Then in the Options menu, Controls Surfaces, enable the Generic MIDI control surface, and then choose Options / Control Surfaces / Controls / Feedback. (for some reason I have to do this everytime I launch a session, this must be a bug).
This ensures that you want to map controls to MIDI events, and get the response from Ardour to OSCulator.


OSCulator MIDI Configuration

In OSCulator, open the Parameters Window, then go to the I/O tab and select the "control" MIDI port for both input and output (Select active MIDI inputs -> control, Select active MIDI outputs -> control).


OSCulator OSC target Configuration

If you are using the Lemur, you need to setup OSCulator so it sends OSC back to the device. For this, you need to know the either the Bonjour name of the device (for example if you named your iPad "Balivernes" in iTunes, the Bonjour name is "Balivernes.local.", note the ending dot in the name). It is highly recommended that you give a simple name to your device, like a single word. So, change the name in iTunes, and reboot the device.

Alternatively, you can use the IP address of your device, something like 10.0.0.14 (but I don't recommend it).

So, back to OSCulator, in the Parameters Window, go to the OSC tab, and edit the default target so it look like the following picture. All you need to do is double click in the host:port field of the default target and enter "iPadBonjourName.local.:8000". Lemur listens for OSC messages on port 8000.

If you use the IP address, you enter "10.0.0.14:8000", replace 10.0.0.14 by the actual IP address of your device.
215

The screenshot is taken from OSCulator 2.12-beta5, so you might not see exactly the same thing if you use an older version, but the idea remains the same.


OSCulator to Ardour Mapping

Now, register some messages in OSCulator from your faders and knobs, and map them to MIDI CCs (like you did in the file you sent me).

In Ardour, now hold the Control key and use the middle button of your mouse on a fader. The message "operate controller now" should appear. If you don't see this message it can be either that:
1. you don't hold the Control key while clicking on the fader or button, or your mouse doesn't have a middle button.
2. you have not enabled the Generic MIDI control surface.When you see the "operate controller now" message, move a fader that was mapped to MIDI in OSCulator. The message will disappear and the fader will start moving.

Since you have enabled MIDI feedback, OSCulator will receive the MIDI back from Ardour, and because you have configured your iPad to be the default OSC target, OSCulator will automatically create a OSC message back to the device.

I hope this is all clear, if you have any question please feel free to ask.


Best,
Cam

OoGuN
03-07-2012, 09:45 AM
Hi Camille,

Thanks a lot for the help and the in-depth explanation. I now have feedback happening for faders and the mute/solo switches and as you said, it's very easy to set up. There are a couple of things I would add: once you have got mixbus responding to the Lemur, you need to then operate the fader or button in Mixbus and this makes the OSC routing appear in Osculator. The other thing is that it seems that Mixbus does not send feedback for knobs? I can control the knobs in Mixbus with Lemur, but the lemur knobs still do not respond if I turn the knob in Mixbus. I will ask the Harrison guys if this is the case and report back.

Oh and sorry I should have mentioned what a pain it is to get midi learn going in Mixbus, luckily even the magic mouse has a middle button mode :)

All in all things are going waaaay better now really appreciated you taking the time to help me with this.

best

Kola

Syme
04-26-2012, 08:55 PM
Hi,

I'm doing the same thing using TouchOSC to control Mixbus via midi so setup was the same. My question is concerning resolution of the faders.
I find that I'm missing steps in the fader gain, for example: between -1 and 0 db I can stop at -1.6 and -1.3 but the othe 7 steps are missing; also I am unable to stop at 0.0 db. This makes sense of course because of the 128 midi steps. I then tried using midi note pitch bend (16383 steps) but that got weird and I was only able to achieve negative values between -140 and -11. The funny thing is that the TouchOSC fader will follow to any position in the other direction, in other words following feedback from dragging with the mouse in MB.
Do you have any suggestions to resolve this?
Thank you.
Simon

OoGuN
04-27-2012, 02:51 AM
Hi Simon,

I'm not near mixbus at the moment, but I think when I was trying to resolve my issues I actually went onto the mixbus irc channel and asked them what the fader law was and that helped me to get my faders responding properly. I'll see if I can dig up the conversation I had with the Harrison guys when I'm back at my other comp.