PDA

View Full Version : Osculator iPad2 and bluetooth



bleach30
06-18-2012, 10:48 PM
Just wondering if its possible to connect my iPad 2 to Osculator via bluetooth instead of wifi. My computer is AUDIO02 and it shows up in the OSC routing tab
and on my iPad I am connected via bluetooth to the same but it doesn't seem there is any communication. Am I missing something or does it just not work that way. It works great through wifi but i need it to connect bluetooth elsewhere for various reasons. Awesome program by the way.
iPad2 iOS 5.1.1
Osculator 2.12.03

Thanks

camille
06-18-2012, 11:59 PM
I don't recommend using bluetooth, but if you really want to try this solution, you can try this tutorial, but instead of using USB, you use a Bluetooth PAN network (requires a jailbreak):
http://www.osculator.net/2010/07/19/osc-and-ipad-on-a-usb-connection/

Note that this article is pretty old, so YMMV.

I'm curious to know what are the various reasons preventing you from using a WiFi network.


Cam

bleach30
06-19-2012, 12:31 AM
wow that was fast!

I know I, wouldn't normally either but its because where I work has limited network resources so using a wireless network isn't an option. The computer Im using is right next to me so it shouldn't be that bad. I just tested on my laptop (Macbook pro OS 10.7.3) and it worked through bluetooth just fine. Its just not happening on the work computer (Mac Pro 10.7.2) hmm..wonder if its an OS issue? Maybe its an address somewhere I'm just not seeing. It looks like I have network, bluetooth,sharing prefs set the same but could be missing something.

Thanks for the quick response!

camille
06-19-2012, 12:38 AM
A recent update to TouchOSC defeated the usefulness of Bonjour service discovery (i.e. detect OSCulator running on the network), which means that you might need to re-configure TouchOSC's OSC settings before being able to send message to OSCulator. I can't tell for sure though that this is the problem you are having, but it is always a good idea to make sure networks settings are correct in TouchOSC.

bleach30
06-19-2012, 01:14 AM
It appears that on the work computer in the Network pref for bluetooth PAN there are no devices found. I think thats the culprit. The status says connected and the iPad does see Osculator but the network isn't seeing the iPad. The IP addresses are correct.

On my laptop however the iPad is detected and connects.

bleach30
06-20-2012, 04:17 PM
update:

updated the Mac OS to 10.7.4 and that fixed the problem for me.

camille
06-21-2012, 09:23 PM
Alright!
Thanks for letting us know.