PDA

View Full Version : Osculator Velocity channel bug?



iogurt
06-19-2012, 10:50 AM
Hi dear Camille.

I'm working on a document that routes several midi notes from NanoPad midi in (ch5) to Midi Osculator midi out ch3 or ch4.

I have a problem with all the Channel Velocity MIDI CC routes. The channel of all messages of this kind are rewritten to midi channel 1 all the times i open the document. Doesn't matter with what channels i've save the document. When i open later all the Channel Velocity routes are switch to channel 1.
Also doesn't matter if i lock the input or not.
For example, i route midi midi note 52 (comming from nanopad ch.5); velocity to | MIDI CC | Channel Velocity | Ch. 3 |. And then i save the document. I can work properly but if quit osculator and re-open the midinote 52 velocity has midi ch. changed to ch 1.

My Osculator vrsion is 2.12.0.3

Can be a wrong routing or maybe a bug?

PD: I found that copy/paste works fine between presets but for debugged messages. There is a way to achieve this?

Thanks in advance for all your support.

Regards

Iogurt

camille
06-19-2012, 12:53 PM
Hi iogurt,

That's correct, this is a bug was introduced in version 2.12.
I will release a bunch of fixes later today.


PD: I found that copy/paste works fine between presets but for debugged messages. There is a way to achieve this?

Can you elaborate a bit?

Thanks!
Cam

iogurt
06-19-2012, 01:50 PM
Hi Camile.
Thanks for your speed.


PD: I found that copy/paste works fine between presets but for debugged messages. There is a way to achieve this?

Sorry, not "debugged". http://static.osculator.net/forum/images/smilies/wink.png I wanted to say:
...but not for demuxed messages.You know, englysh ys beri isy for mee. http://static.osculator.net/forum/images/smilies/tongue.png

When i attemp to copy messages, or duplicated messages (i didn`t try with splits) from preset 1 to preset 2 works fine. But if the message has previously demuxed it is pasted in preset 2, but no responses from the source. Needs to demux and route again each message individualy for every preset you use copy/paste.


Awesome program, man.

Iogurt

camille
06-19-2012, 04:28 PM
I have tried to copy/paste a demux'ed message from one preset to another or one document to another. I believe it is working properly, though I can see the issue you are describing.

One rule of thumb to keep in mind at the moment: when you copy message (and paste them elsewhere), what is copied is the whole OSC message (/foo/bar, and everything that is related to it : arguments, duplicates, demux'ed elements). This is the lowest unit, which means that you can not copy just a detail of the configuration of this message (for example a single duplicate). I understand this is annoying, but I have no solution right now :eek:


Best,
Cam

PS: FYI, splitted messages are just duplicated messages but with altered scalings.

iogurt
06-19-2012, 11:41 PM
Ok, i think i've understood. So, i must copy all the message and erase the unnecessary routing on the new preset. Is not much annoying if you know the reason.
I hope you can release soon the fixes for the velocity issue.

Best..

Iogurt

camille
06-20-2012, 12:21 AM
Hi iogurt,

The update is online and available through the automatic software update.


Best,
Cam

iogurt
06-20-2012, 02:56 AM
Great!!

Thanks Cam. Incredible support.