PDA

View Full Version : Anyone using Lemur with Osculator?



fader8
07-21-2012, 04:16 AM
Hi!
fairly new to Osculator, trying to send OSC messages with Osculator that Lemur will respond to. Haven't quite figured out how to send these. Apparently I will need to know what port Lemur receives on but Lemur doesn't seem to publish that info or allow it to be set by the user. I want to send different messages to multiple IOS Lemur devices. Scouring both the Lemur and Osculator manuals hasn't helped, unfortunately. Any seasoned Lemur-Osculator users out there?


Ive managed fine with sending messages from the devices to Osculator which converts them to MIDI, but I need to go the other way now. MIDI to Osculator to Lemur using OSC. Actually quite surprised there is so little info available on how to do this. Anyway, any help appreciated. Thanks for your time!

camille
07-21-2012, 05:29 AM
Hi fader8,

The default OSC input port for the Liine Lemur is 8000.

So, if you know your iOS device's IP address, you should create a OSC target with the IP and port information:
Open the Parameters Window, go to the OSC tab, and in the table at the top enter the IP address and port separated by a colon.
If you set this target as the default OSC target, information going from Lemur to MIDI should be automatically translated back from MIDI to Lemur.

I don't know exactly what you are trying to map, or what message you need to send to Lemur, but that should be enough to help you get started. The OSCulator manual contains much more information about OSC targets and message routing.


Best,
Camille

fader8
07-21-2012, 04:42 PM
Thanks Camille!
OK, I have my routings set up in parameters to my 5 IOS devices. 2 iPads, 3 iPhones. So......

Ive created a fader in Logics environment. it sends cc107 on ch 15. It's wired to an instrument whose port is set to Osculator In (9004).

Osculator window open (OSC Input Port is 9004).

Move the fader in Logic, I capture "/midi/cc107/15" in Osculator. So far so good! I now set the event type in Osculator to OSC Routing, value 2, which is my iPad on 192.168.2.4:8000

So I create a fader in Lemur with the custom address of /midi/cc107/15. Load that project into my iPad. Moving the Logic fader moves the Lemur fader. This is great! I'm feeling pretty proud of myself at this point! But........ I lose the ability for the Lemur fader to control the Logic fader!

Of course, If I set the event type for this message in Osculator to midi cc, value 107, channel 15, I see that coming into Logic on The Osculator midi port, and that lets the Lemur fader control the Logic fader, but then I lose the OSC routing and I don't get feedback to the Lemur

In summary, I can get the Logic fader to control the Lemur fader, or I can get the Lemur fader to control the Logic fader, but I'm failing to grok how I can get them both working at the same time. I think I must be missing something pretty obvious here!

Thanks for your help!

fader8
07-21-2012, 06:53 PM
OK, I think I have this figured out! I've created 2 Osculator windows for my IOS device, one on port 9004 to receive MIDI from Logic and then sends OSC to Lemur iPad, and another window (port 9040) that receives from Lemur iPad and sends MIDI to Logic.

This gives me full synchronization of the Logic and Lemur faders. With that, my question now is if I have to have 10 windows to handle all 5 IOS devices, or can I just use one and have all the devices be set to the same port number. Obviously they all have different IP addresses, but I was wondering if there's a broadcast type scenario that would make this work?

dchild
04-19-2013, 01:36 AM
Hey - i'm having some issues getting OSC messages to feedback into the lemur. I've tried setting the default OSC target as camille suggested (ipad IP):8000. But it doesn't work?

Any suggestions? There's a real lack of information on this topic in the Lemur manual and no one on the lemur forum is whiling to help me.

@Fader8 - Can you explain in detail how you got this working? Any screen shots showing the setup would be much appreciated.

I've spend weeks designing / Building lemur templates for my live set, this is the missing link to the live set of my dreams!

camille
04-19-2013, 08:42 AM
Hi dchild,

It's too bad Lemur's input is so difficult to configure.
(I asked Liine (iPad Lemur's publisher) to add Bonjour automatic network configuration, and even sent code for it...).

I am not sure wether Fader8's solution really needs two windows. One should be enough.

So, I just tried a very simple setup with a basic fader controlling another one in Ableton Live. I had to enter my iPhone's IP-address:8000 in the OSC targets and make it the default OSC target. Once a MIDI CC was mapped to a Live control, the bi-directional process occurred as expected.

I need more details to give you a better answer. For example, what software of device you would like to control bi-directionally? This one has to have bi-directional abilities so OSCulator can route the feedback to Lemur. Are you seeing any MIDI input in OSCulator? If yes, is it mapped to an OSC Routing or not?


Best,
Cam

dchild
04-19-2013, 09:08 AM
It Would be a great help just to see your simple one fader setup.

Could you post the lemur / OSCulator templates.

dchild
04-19-2013, 09:12 AM
Could you explain this... "I had to enter my iPhone's IP-address:8000 in the OSC targets and make it the default OSC target. Once a MIDI CC was mapped to a Live control, the bi-directional process occurred as expected.

I'm sure i'm missing something

camille
04-19-2013, 09:15 AM
Sure, in Parameters, OSC Routing tab, I entered 10.0.0.12:8000 in the first available OSC Target slot, and made it the default target by making sure the radio button was selected for this target. I will send you an example file soon.

camille
04-19-2013, 10:11 AM
Here is an oscd file and here's how I did it:



On my iPhone, I opened Lemur and chose the template "iPhone - Basic Faders".
Still in Lemur, I configured my computer as a OSC Target. For this I used my computer's host name "tortilla.local" and 8000 for the Port (you can find your computer's host name in the Sharing Preferences Pane, look for the comment below the computer name.)
I opened OSCulator (checked it was running on port 8000), and touched the first fader on the Lemur to register it. The messages /Fader1/x and /Fader1/z appeared in the list of registered messages.
Then I opened the Parameters Window, OSC Routing tab, and configured the first Target to 10.0.0.22:8000 (IP address of my iPhone and input port of Lemur, which I found in the WiFi Settings of my iPhone). I checked that this target was the default target.
I mapped MIDI CC 10 to the input message /Fader1/x.
In Ableton Live, established the mapping between OSCulator and the volume fader of the first track.


OSCulator then automatically created a routing back from MIDI to OSC in response to Ableton Live's feedback.

dchild
04-19-2013, 11:40 AM
435

Thanks so much, its working. GREAT NEWS.

My problem was the value column. how did you get the fader values to show up i.e. D>Fader1/x:f?

When i started modifying your template it auto populated. I tried adding another target for my second ipad, but i'm missing the >Fader1/x:f?

Am i right in thinking i need to add another target for my second ipad?

dchild
04-20-2013, 01:07 AM
I found some information regarding 2X ipad setup on another threat.

I think i have identified a potencial problem, both lemur input ports are hardcoded to 8000. This means i wont be able to run mulitple windows. As it will say the port is already in use.



If you want to use many networked devices, you must use one document (one OSCulator window) per device. Once all the devices are on the network, each of them will have to be configured with its respective document, and the document's default OSC device must be set to its corresponding device manually. This is done in the Parameters Window, OSC tab, and set the radio button in the upper table to the desired device.
If each of this device needs to communicate bi-directionally with MIDI, it is much advised to create a IAC bus per device and set each document to use the respective IAC bus. The IAC busses must also be set as inputs in Live.

dchild
04-20-2013, 03:44 AM
436

Another issue mapping the multislider. I've set different CC outputs for the different sliders. But Ableton is only mapping to CC 102. See screenshot attached.

My head hurts...

camille
04-20-2013, 09:55 AM
I think i have identified a potencial problem, both lemur input ports are hardcoded to 8000. This means i wont be able to run mulitple windows. As it will say the port is already in use.

This is not true. Since the port is used on one iPad, it remains free on the other iPad and therefore both iPads can use the same port number. If you would like more information, there is a simple explanation of this in the first chapter of OSCulator's manual.

Otherwise the procedure is correct.

camille
04-20-2013, 10:01 AM
The multislider message has multiple arguments, therefore all MIDI CCs are sent every time the multislider message is received. You can see that easily with a tool like MIDI Monitor (http://www.snoize.com/MIDIMonitor/). BTW, this is a much recommended tool to use.

Ableton Live will map only the last MIDI CC received, which means that if you want to map different arguments of the multislider message, you have to "solo" each argument for each slider you want to assign in Ableton Live.

dchild
04-24-2013, 09:24 AM
Hi Camille, I'm glad to report all is now working.
I'm using two OSCulator windows configured for both my ipads.
Thanks for all your support and feedback.