PDA

View Full Version : Include tablet mouse disable as part of the preset



rkuivila
06-30-2015, 05:55 PM
The title says it all - right now, you have to open osculator and type the command key to disconnect a Wacom tablet from the mouse
cursor. It would be nice if there were a checkbox or something to just save this as part of a preset.

Also, I have run into a situation where the mouse disconnect stops working and requires a reboot. Is there any known issue?

Cheers,

rkuivila

camille
06-30-2015, 06:26 PM
Hi rkuivila,

This is an interesting idea: you could be able to lock the mouse cursor from a OSC message.
On a preset change OSCulator can generate an OSC message, and you would simply hook the mouse lock event to that message.

About the reboot issue: there is no known issue at this moment, would you mind sharing your operating system version?
I am assuming you have the latest version of OSCulator.

Could you try the following if that happens again: press Command-Option-Escape and quit OSCulator by using your keyboard (since the mouse does not work). Does it release the mouse again?


Best,
Cam

rkuivila
06-30-2015, 08:04 PM
Hi rkuivila,

This is an interesting idea: you could be able to lock the mouse cursor from a OSC message.
On a preset change OSCulator can generate an OSC message, and you would simply hook the mouse lock event to that message.

About the reboot issue: there is no known issue at this moment, would you mind sharing your operating system version?
I am assuming you have the latest version of OSCulator.

Could you try the following if that happens again: press Command-Option-Escape and quit OSCulator by using your keyboard (since the mouse does not work). Does it release the mouse again?


Best,
CamHi Cam,

Thanks for your quick reply!

I am using Supercollider and don't know how to generate the mouse lock event that would shut off Wacom control of the mouse.
(Or would I direct the OSC message to some other application?)


The problem I was having was not that Wacom mouse control remained disabled, rather that Osculator was no longer able to disable
Wacom mouse control. This is on OS10.9.5.

Cheers,

RJK