PDA

View Full Version : How to use in ableton?



Freddyboy
12-09-2008, 10:34 PM
Hey!


Awesome product! I use it with my iPod touch, and it works flawless. I just have one simple question. How do i control surfaces such as this:


http://www.ableton.com/r2/pages/tips/2004_10/06.png


Cheers from denmark,


Frederik

camille
12-10-2008, 02:20 PM
Hey Fredrik,


You can control this plugin just as you would control a fader in Live.

If you want, you can follow this tutorial (http://www.osculator.net/wiki/Main/IPhoneOSCulatorAndAbletonLiveTutorial).

Please ask here if you have more questions.


Best,

Cam

Freddyboy
12-10-2008, 05:17 PM
Hey Cam.


I used your tutorial to use ordinary buttons and faders. But I cannot make a X/Y pad learn from midi.. Can you please explain to me in detial?


Thank you,


Fred

camille
12-10-2008, 10:36 PM
Hey Fred,


That is very easy, here are the detailed instructions.
Say you want to want to map MIDI Control Change 0 to X and CC 1 to Y in a Delay plugin (X for the Delay time and Y for the Feedback ratio).


First assign MIDI CC "cc0" to X and MIDI CC "cc1" to Y
As you will notice, OSCulator sends two MIDI control changes at the same time, this is not good for Ableton Live, because it needs to receive only one control change to be able to map a value.


To avoid this, click on the X row and press Command-R (or Apple-R) to "solo" that row.


In live, click on the MIDI icon (upper right) and click on the Delay parameter of your plugin.
Now, move the xy pad, the X value is now automatically bound to Live.
Return in OSCulator, press Command-R to disable Solo mode, select the Y row and press Command-R again, this will solo the Y row.
Back in Live, click on the Feedback parameter of your plug-in to select it for auto-learn and move the X/Y surface in TouchOSC again to send a MIDI message.
Disable MIDI learn mode by clicking the MIDI icon (upper right).
Disable solo mode in OSCulator by pressing Command-R again to restore all routing.


Please tell me if that works well for you.


Cam

Freddyboy
12-11-2008, 08:31 PM
Magnificent it works!


This isnt just an excellent program, but great service too!

I'll donate some extra money by the end of the month.


I salute you,


Freddy

mocker
12-12-2008, 06:34 PM
Good I read this post, I had found a much more complicated workaround. Didn't know about this solo option. Is that in the manual ? If it is, once again I should RTFM… :-)