PDA

View Full Version : Wii set up and Max/MSP/Jitter



rox1908
01-13-2009, 12:23 PM
Hi,


I was using Osculator quite a bit in the early part of last year, but now I seem to have forgotten a few things. I got my wii remote to set up in system preferences and hit buttons 1 & 2 for osculator to find my wii remote. However, over toward the input buttons to the far left I am only seeing the buttons light up yellow, no green. I'm thinking it's not reading my wii remote correctly. As a result the max patch set up to work with the wii remote provided in the osculator folder is not working (at least I think this is the reason)


I made sure the CNMAT-Everything-OSX-macho folder is in my cycling 74 folder.


I also tried deleting the device in my bluetooth preferences in system preferences a couple of times, and adding a new device (to start fresh).


What am I doing wrong?

camille
01-13-2009, 02:22 PM
Hi Roxanne,


Your Wiimote connected perfectly to OSCulator.

The manual says that the yellow light means 'no activity', the message you are monitoring doesn't seem to be connected to anything.


Could you please tell me what version of Max/MSP you are using?

The Wiimote to Max example is currently only compatible with Max 4, not 5.


Also, please check that you have correctly set the input OSC port in Max, as it is not loaded automatically …


By the way, if anybody in this forum has a better Wiimote to Max patch to contribute, it would be kindly welcomed!


Best,

Cam

rox1908
01-14-2009, 12:42 PM
Hmmm...well I recently downloaded Max 5, but I tried the patch in Max 4.5 & 4.6 and nada. The funny thing is that the patch worked perfectly the last time I used it (months ago for a final project)....but now nothing. I would connect my wii remote, then open the Max patch and the position acceleration data would start moving up and down, and I would be able to track my IR source. Now completely nada.


According to the patch my receiving port is set at 9000. Or should I be selecting the input somewhere else in Max?


Also, I know you said my wii remote has connected, but the main difference I can recall from what I did last year and this year is that I'm using a different wii remote. The wii remote I'm using is one I bought used at a game store. If the remote has been paired to something else prior to me using it, could that cause any problems?


Thanks a bunch


rox

camille
01-14-2009, 01:01 PM
Hi Rox,


I don't think your new Wiimote having being sync'ed before should not pose any problem.


In the Max patch, make sure you re-select the input port. I don't think there's a loadbang on the port setting drop down menu, so you may want to force it a little bit.


If you want to be sure that OSCulator really receives infos from your Wiimote, I recommend using the Console Log event. Pick a random wiimote message, and instead of routing the osc, choose "Console Log" in the Event Type menu, and "Simple Log" in the Value menu.


Now, open the Console.app application (in the /Applications/Utilities folder) and look at the result (be sure to select "All messages" or "Console" in order to see something significant). If your Wiimote is well connected and is sending values, then you should be able to see it there.


If you have values, but Max is not receiving them, we will have to search for something else. If your wiimote actually doesn't send anything, it would be a good idea to note down its bluetooth address (in the Bluetooth Preferences Pane), and check if it is supported by OSCulator (it should).


Cam

rox1908
01-19-2009, 01:43 PM
Yeah....it seems that the problem is definitely not my wii remote. I entered an "event type" (OSC Forward) and a "value (localhost:9000), and now I'm seeing the inputs light up green. However, still nothing in Max.


Although in the Max patch the "data" light is lit up blue, and in the Max window in lists all the data its receiving from osculator


example:

data: /wii/2/accel/pry/1 0.689402


so I know osculator is working well with my wii remote and sending the messages. I also know Max is receiving the data from osculator, seen by my data indicator light and tons of data is being printed to my max window when I select print data from my max patch.


But there is no activity going on in my patch. There is information in my Max window, but the bar graphs aren't moving up and down to indicate activity is happening.


Possibly it could be a setting in Max? it could be the port im using? (if i try any of the other ports the data indicator light turns off).


I'm sorry to be such a bother :-(

camille
01-19-2009, 03:34 PM
Hey Rox,


I think you are just steps away from using this patch.

It seems your Wiimote has ID #2, and the patch from what I remember only works with Wiimote number 1. So, all you have to do, is to change the Wiimote's slot to 1, and you're done.


Best,

Cam

rox1908
01-19-2009, 04:39 PM
You're the bomb!!!!!!


It works...thanks a gazillion!!! :-)

paddyj666
04-05-2009, 05:57 PM
Hi,


I am having the exact same problem. Wiimote connects to OSCulator but doesnt showup any info or input in MAX 5.3. I think i have the wiimote set as ID#1 but still no joy. I have been using the max 5 patch that was supplied with OSCulator and the OSCulator preset that also came with it. Am i doing something wrong.


Cheers


Matt

camille
04-06-2009, 04:54 PM
Hi Matt,


Here are a few questions to help me understand what is happening:


- Is there any message in the Max Messages window that could be helpful?

- Are you sure you installed the CNMAT extensions before starting the Wiimote To Max patch?

- Is the Wiimote properly connected to OSCulator?


Thanks!

Cam

paddyj666
04-11-2009, 08:10 PM
Thanks for the reply Cam, turns out i didn't install CNMAT extensions. All working fine now. However I am getting a slight latency when using the Wii remote with MAX MSP and Reaktor. Is this normal? The latency is there regardless of what software i am using.

Thanks again


Matt

camille
04-12-2009, 09:37 PM
Hi Matt,


I've seen that you posted a FAQ question, thanks!

I've made a reply, in the hope it will be useful for you.


Best,

Cam