PDA

View Full Version : Problems with trackmate and dropped signal



bloton
05-28-2009, 11:25 PM
Just came across osculator yesterday and am very impressed. Still using the demo version so I'm not sure whether my problems would be resolved when I get a license, but anyway...


I've been using trackmate on dual core macbook pro


http://trackmate.media.mit.edu/


Osculator recognizes input from trackmate no problem, and yesterday everything was working fine. I managed to use osculator to convert trackmate messages into MIDI messages and then control synths in Ableton Live. Needless to say I was very excited.


But, today I've been having lots of problems with osculator dropping the signal that it is receiving from Trackmate pro. I was using the online signal monitoring window to look at the Trackmate input, and it seems that osculator would randomly drop the signal for 5 seconds, then work for a second, then cut-out again. I had Trackmate running simultaneously and could see that it was still monitoring the location of my blocks. Anyway, I'm new to both programs, and this could be causing problems. Any ideas on why I might be getting dropped signals? If I can figure out the problem, I'm definitely going to get that license, cause this program is awesome.

bloton
05-28-2009, 11:41 PM
Looks like I figured out my own problem. It seems that I had made some changes to the resolution on my camera settings in Trackmate, and while Trackmate appeared to be tracking my objects, it wasn't sending a reliable signal to osculator. Now that I have my resolution back to the way it was yesterday, no dropped signals yet! So now I can get back to hooking my synths up to wooden blocks.

camille
05-29-2009, 11:24 AM
Hello bloton,


Thanks for your enthusiastic messages.

In the new version (2.8.2), there is a cool feature that enables you to monitor the incoming signals.

Just select a line in the main window, and press the Space bar. You can also select the Quick View toolbar item. This is useful since you can read the current value and see when signal is received or not.


From what I know the OSC network connection is very reliable on a local network. So in case this kind of problem happens again, you can rule out this eventuality.


If you ever do something with Trackmate and OSCulator, I would be interested to hear more about, so don't hesitate to post your results on the forum :-)


Best Regards,

Camille