PDA

View Full Version : system/instrument volume via tilt



Hatchinatore
07-19-2009, 08:12 PM
im in a band using osculator and garageband with the wii guitar, some parts of the song i have to be quieter than others and the synth i am using for some reason doesnt support the velocity control as most other instruments do. is there any way to get velocity to work with my synth other than the midi note channel velocity option (other instruments work with this but not the one i need) or is there a way to control volume prefferebly?

camille
07-20-2009, 07:45 AM
Dear Hatchinatore,


i would suggest you control the channel volume. basically here is what to do:


- set the MIDI CC 7 (channel volume) to the wiimote parameter you want to use to control the volume.

- change the channel number to the one that is used by the track in GarageBand.


Now the tilt of your guitar should control the volume of the track.


I would suggest you now go in the scalings page (click on the little page curl icon on the top right of the main table) and search the line that correponds to the parameter you just configured and adjust the "output min" to a value that will be you lowest volume (try 0.5 for a start).


Best,

Cam

Hatchinatore
07-21-2009, 04:25 AM
you rule. also i have another request, if it is possible cold you add an option to set delays to individual commands? for example i could play a chord right now but it would almost sound like a note. all the chords are played at the exact same time unless they are on different buttons. and not only that, but all of the guitar synths sound like pianos haha. so what delays would enable you to do is create flowing chords as if you are actually strumming a guitar per-say. i could set 3 individual notes to a fret button,activated by strum. if i were to go to where these 3 notes were, i could set the first delay to 0 the second to .05 and the third to .1 so when you would press the note, it would play them in sequential order, giving gaps like an actual guitar whilst playing fast enough to sound like a chord. an even further suggestion would be to e able to control the spread of the delays. for example by using some sort of variable control i.e. whammy bar or tilt on the wiitar, you could change how fast the strum is, i could tilt the guitar up and achieve a slow resonating strum, and if im going fast, i would want almost no gap. this would be the most incredible and realistic guitar synth. also i would love you forever. but its just a suggestion, a suggestion that could put osculator at the top, i know quite a few people who would appreciate something like that. and it could increase customers by a lot.

camille
07-21-2009, 10:03 PM
This is a very good suggestion indeed, and I will write it down in the feature requests list.

The current version of oscltr is unfortunately not ready for that in the near future, but in a longer term I will surely implement such ideas.


In the meantime I would suggest that you take a look at MIDI plugins that will help you to control MIDI data and generate the delays you want. Although I have no suggestion to make, I am almost sure some exist.


Thanks again for the suggestion!

Hatchinatore
07-24-2009, 06:29 PM
thats awesome! sadly ive run into another speed bump. i have a couple configurations set one of them i have had the most issues is getting strum activated notes to work without fail or lag. currently all the notes are stored in the strum bar and the fret buttons are using the latch commands to enable the specific notes. this is the easy part. the problems start when i go faster. if i release the fret (latch) before i release the strum bar the note will stick and then all of my sound is overplayed by that note until i play it again properly by releasing the strum bar first.

ways i have attempted to fix this are the following:

setting the strum bar to set the volume to zero until i strum then set it to max. this did not work, the sustained note remained stuck even though the volume was zero and it didnt sound until i re strummed. second method i tried was to use the same logic, but with velocity, so that possibly when velocity was zero the note just halted. i dont know why but that failed too. lastly i tried using midi cc to send a command when the strum bar was released that said kill all notes, that didnt work, maybe im using the wrong command? i used # 123. do you have any suggestions to kill the sustained note? thanks a bunch for your help by the way, i really appreciate all the hard work that has gone into the program and helping out people like myself

camille
07-24-2009, 10:38 PM
Ah, yes Hatchinatore, I totally see what you mean.

Either this is a bug or a feature, I don't really know yet.

Please let me think about this issue, and I will hopefully come with a simple solution.