PDA

View Full Version : touchosc midi mapping in ableton live



selcuk
11-17-2009, 03:01 PM
Hi,


i'm using ipod touch version 3, touchosc and osculator to communicate with ableton live. I've tried the tuttorial several times but i have a problem that gives me a headache.


i can assign just one controller in ableton. If i'm going to try to assign another controller it changes the cc number to the first controller that i've assigned before. I can see that in the midi mapping window of ableton. I've tried everything that i know but i can't fix it.


How can i solve this problem, please help me.


Thank you


Selcuk

camille
11-18-2009, 12:42 AM
Hi Selcuk,


Please check the following:

- make sure you have different MIDI Control Change number for each TouchOSC control. They have to be different or they would collide

- In Live, when you assign a new controller to a user interface control, make sure you don't select the same as for the previous mapping, or it will be replaced by the new mapping.

- If you are using a control that sends multiple values at the same time (for example X/Y surface), make sure you only send one control at a time. For this, select the control you are going to map, hit Command-R in OSCulator to enable solo mode for this control, and assign the control in Live. Hit Command-R one more time to get out of solo mode.


Best,

Cam

selcuk
11-18-2009, 08:36 PM
Hi Camille,


Thanks for your reply.


I've checked all of them but nothing changes. That is intresting but i can easily mannage the x/y control. I'm having trouble with the buttons. When i try to assign a cc to a button something happening and suddenly changes it to the last assigned slider or x/y controller. It's like a midi feedback problem but i can't understand it.


Also i see a ping message on the osculator is it normal?

selcuk
11-18-2009, 08:45 PM
Ok i gave wrong informaton, it is not only button problem. After assigning two cc's i can't assign any different one.

camille
11-18-2009, 11:22 PM
Hey Selcuk,


If you think there is a MIDI feedback, what you can do is start controlling Live in only one direction (OSCulator to Live), that not enable bi-directional control (Live to OSCulator).

For this, you should go in Live Preferences, and disable Track and Remote on "Output: OSCulator In (8000)".


I'm not sure to fully understand what's happening there, as for the ping message, I don't think TouchOSC sends such messages.


Best,

Cam

selcuk
11-19-2009, 12:25 AM
I find the problem! :)


I disable the iac midi ports and now everything is fine. In the past i've try to use wiimote with other prog. that i forgot its name. I used iac midi ports for that application. Ok it works great right now.


I can register now.


Thanks Cam

camille
11-19-2009, 09:13 AM
Excellent !

Great to know it is working.

my808
12-06-2009, 07:13 AM
Hi,


Ive just started using TouchOSC with Ableton 8 (Windows 7) but I am getting a very simialr problem. Ableton maps teh first controller, and the second, but anything after the second mapping gets the same CC number. From MidiMapMode, when I click on an Ableton control, then wiggel my TOuchOSC iPhone knobs you can see the correct cc number flick up for a moment but then it changes (very quickly) to the second CC number.


Does anyone have a fix for this please?


Thanks

my808
12-06-2009, 07:29 AM
I just noticed that sometimes when I try to map a cc that ableton flickers between the correct cc number and the last one I used. It just flicks between the two controller settings by itself (very fast), it stops when I leave MidiMapMode. Also I noticed that I cant delete the mappings sometimes, until I come back out of midmapmode and go back in... really weird

camille
12-06-2009, 11:13 PM
Hi my808,


The problem you are having here is that you are sending other control changes while you assigning a new one.

Live doesn't filter out already assigned MIDI control changes, so the trick is to solo them as described in this thread:


http://www.osculator.net/bp/topic/105#post-542


Hope this helps!

Cam

my808
12-07-2009, 12:05 AM
Thanks Camille!


I cant tell where to solo out the cc. Is it in midimap function in Live? Or from Pd somewhere? Sorry mate and thanks!


Your Qoute: "The trick is to "solo out" only one parameter at a time.

There are checkboxes on the left that you can use to fire the events or not."[i]

my808
12-07-2009, 07:15 AM
I tested on my other notebook today and it worked! It must be my Dell M1530 AGAIN! I will never buy a Dell again.


Thanks Camille

camille
12-07-2009, 10:27 AM
The MIDI events are sent from OSCulator, so you have to solo them in OSCulator, this is in the Routing menu, you can also use Command-R :


http://www.osculator.net/dw/manual:main_user_interface#routing_menu


cheers!

cam