View Full Version : Wiimote "rolling" blocks other Input in Ableton Live

03-14-2010, 08:00 PM
I am controlling the autofilter of a track by pressing the A button on the wiimote (turn effect "on" while pressing) and the Hz setting by rolling the wiimote.


the problem: as long as the rolling input is activated in Osculator the Ableton Live view totally stays locked on the track view where the related auto filter related to the "rolling" is and blocks some input. I can still fire loops but double clicking another track to view its details does not work then. It just makes the display flash but not activate the other track's view. After deactivating the "rolling" input in osculator I have normal access to other track views. no more "locking".

Is there something wrong with my "rolling" event setup in Osculator?

I appreciate any help.

03-14-2010, 11:48 PM
It looks like your computer is overloaded with the messages sent by the roll parameter.

As a workaround, I would suggest that you duplicate the /wii/2/button/A message, and assign a "Latched Enable" event, whose value would be the roll parameter. Click on the enable checkbox of the roll parameter to make it inactive by default. When you press button A, it will send the MIDI control change message 1 on channel 3 and activate the roll parameter message sending as well. Thus, when the button is not pressed, it won't mess with your Live session.

Note that this is just a workaround, and not a real solution. FYI, I have not seen this problem before. It would be useful to know what computer your are using and what version of Live is installed.

03-17-2010, 01:23 AM
thanks. works perfect now. … no more "view locking" :)

i just wondered why does the focus switch to the auto filter when I use the rolling via osculator.

this doesn't happen when I use other midi controls (the input would be applied but the view would not change to it).

using a macbook unibody 1st gen and ableton live 8

03-17-2010, 10:53 AM
There must be a slight difference in your Live configuration between what you are doing with oscltr and what you are doing with other MIDI controllers. Out of curiosity, have you ever configured a control surface in your Live preferences?