PDA

View Full Version : TouchOSC duplicate midi cc control sync across >1 TouchOSC pages



sunnyd76
05-11-2010, 10:15 AM
Hi Camille


I've been away from osculator for a couple of months now, but with my iPad shipping in a couple of weeks i wanted to touch base with a couple of issues I found previously


The main issue I had was when configuring TouchOSC with >1 page that had controls which referenced the same midi cc or note, the controls wouldn't behave correctly. Therefore there would be something like this:


/page1/filter1 channel 11 cc1

/page2/filter1 channel 11 cc1


These would be congfigured under the same preset. I found that the controls behaved oddly in that because the controls were on different touchosc pages, control values on both pages wouldn't remain in sync.


Is this something that can be fixed or has been fixed? If not, is there a workaround for this? Maybe this is possible using presets somehow?


Cheers,

Sunil

camille
05-14-2010, 08:48 AM
Hello Sunil,


As you found out, when the same control change / channel combination is used on two controls, there is some kind of clash with regards to the bi-directional communication.


The solution of using presets with solve the problem for sure.

Another solution would be to manually duplicate the /midi/cc11/1 message and create another OSC routing back to /page2/filter1.


A last option would be to automate the automatic back routing (which would require an update to OSCulator). Like in the previous solution, the /midi/cc11/1 message would be duplicated so it routes back to two OSC Routings (/page1/filter1 and /page2/filter2). The only prerequisite would be to have MIDI CC 11 / 1 already configured on two OSC messages so that when the first MIDI message is received, OSCulator knows that it must route back to two destinations.


Thanks for letting me know this.


Best,

Cam

djenferno
06-01-2010, 02:59 AM
Camille,


I'm trying to the same thing here. I'm having trouble getting a toggle button to stay in sync on 2 different pages of my Touchosc template.


I'm doing the following:


/1/Toggle_TT CC58 Channel 7

/2/Toggle_TT CC58 Channel 7


on the incoming message:

/midi/cc58/7


I tried duplicating and routing the second back to /2/Toggle_TT. It looks like this:


/midi/cc58/7

0 OSC Routing Default: iPad (TouchOSC) -> /1/Toggle_TT

0>0 OSC Routing localhost:9000 - > /2/Toggle_TT


This isn't working. What am I doing wrong? I simply want to mirror a button (both outgoing and incoming) on 2 pages.

camille
06-01-2010, 09:06 AM
Well, your iPhone has certainly not the address "localhost" on port 9000.

You should enter your iPhone's host name and port in the routing in order to have it work properly.

This FAQ item will help you finding your iPhone's host name : http://www.osculator.net/doc/faq:iphone#how_do_i_know_what_is_the_ip_a


Cheers,

Cam

djenferno
06-01-2010, 10:33 PM
Thanks. I corrected the address to "IPad.local" and it worked.

camille
08-02-2010, 02:01 PM
This problem has been solved when you use the latest 2.10 release.