No announcement yet.

Problem with Wiimote Accelerometer signal

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Wiimote Accelerometer signal

    I am not getting any accelerometer readings from my wiimote. When looking at the "Quick Look", the reading stays constant even though I am moving the remote. Right now only "Pitch, Roll, Yaw" is checked under outputs. MotionPlus is set to continuous mode, though I do not have motion plus, so assume this has no affect.

    I was able to install and connect to the wiimote with out any problems. When I press the the buttons, I see the yellow or green active square and am able to get readings in the quick look as well. The "pry" section of the message gives an active box but the individual pitch roll yaw and accel are not lit, though they are checked as being active.


  • #2


    Could you please give me the bluetooth address of your Wiimote, please?

    Have you tried unchecking / re-checking the PRY checkbox?

    Maybe you can try with the IR button as well.

    Since the pry messages are displayed in the list, this means they have been sent with a value at some point. It would be also useful to open a quick look window on the pitch argument for example, save the document, quit oscltr. Then open the document, connect the Wiimote and see what happens in the Quick Look window …




    • #3

      I tried the test you gave me (saving and reopening) and got the same values for pitch (.51) as before the relaunch.

      I also tried checking and rechecking. Raw Accels and Raw IR both have constant values and IR(x, y) gives me nothing.

      My address is:



      • #4

        Ok, your Wiimote should be properly supported.

        I understand the Wiimote sends accelerometer readings only once, which is strange but makes me think of a timing problem when using the wiimote with some computers / OS X versions.

        Could you please check if the Perfect Pairing extension is properly installed? You will find the information in the Preferences window, Inputs tab. If it is already installed, it would be a good idea to uninstall it (uncheck the button) and reboot the computer, then reinstall the extension and finally try to connect the Wiimote again.

        It would also need to know what computer and system version you are using.