No announcement yet.

Guitar Hero Drums as MIDI instrument

  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Hi Nigel,

    I have just downloaded and tried the kit without the Wii Drums for the sake of the experiment.
    It seems there is a difference between Apple's drum kits and Boldt's.
    The ones from Apple do last even when a short note is played, whereas Boldt's do stop as soon as the note is released. I think this has to do with the way the virtual instrument is configured (I guess his instruments are based on the EXS sampler, which has an option to let the sample go through the end even for short notes.)

    I think the best would be the let Boldt know about this issue as it would benefit to every of his users.
    Thanks for letting us know about this nice collection of virtual instruments!



    • #32
      Thanks Cam,
      I've sent a message to Ben Boldt and hope he can shed some light on this.


      • #33
        Hi Cam and everyone. Sorry to wake-up this old post, but...

        I try to connect a Band Hero Drum with a wiimote to osculator for drum playing, but i have many issues.

        The wiimote sends more than one pad signal when i hit a pad (or pedal). But don't send any Velocity information. In other pads when i'm hitting maybe i have trigger and velocity, maybe only trigger. This issues are randomly moving into the pads each time i reconnect the wiimote. I've tried to re-pairing the wiimote, connect out of the drums, connect inside the drums, de-clicking HID Virtual Jostick extension and rebooting... nothing works. I also tried whit two different wiimotes with same results.
        In a midi monitor in logic, i can see notes off, 2 or 3 notes send at the same hit or velocity stucked in a random number (sometimes 0, and nothing sounds) when i hit the pads.
        If i connect cables to the midi ports of the GH drums i can play in a very finest way trought midi-usb adaptor, bypassing Osculator), but is not wireless.

        EDIT: If the signal received by osculator comes from midi-usb adapter i receive a message /midi/note/10. If i demux every pad then i have 6 midi note numbers with a submenu '0:velocity and 1:trigger'. That's work fine (but again, not wireless and maybe redudant).

        It seems that the wiimote is sending messy-messages when not connect with midi cables.

        I hope you can help guys.

        This is the drums model:
        Last edited by iogurt; 01-15-2013, 01:50 AM.


        • #34
          Hi iogurt,

          I will have a look into this and keep you posted.
          Thanks for notifying this problem!



          • #35
            Thanks Camille.

            Here a little bit more information:
            I follow the instructions in this post and i gave the same results at all.
            I'm working on Snow Leopard 10.6.8 and Osculator 2.12.5, with genuine nintendo wiimotes.

            EDIT: I made a video example.

            Regards, Iogurt.
            Last edited by iogurt; 01-15-2013, 12:47 PM.


            • #36
              Hi iogurt,

              I just tested version 2.12.5 and it seems it works as expected with one detail:
              I opened the Wii Drums sample file and noticed the generated MIDI looked like (Note-Off Note-On Note-Off) sequences on each hit of a pad, instead of just (Note-On Note-Off). This is not a problem with Ableton Live though.

              I will send you a build that fixes that minor problem, but I am not sure to understand the problem you have.


              PS: For your information, the HID extension is now only reserved for the HID event type in OSCulator. Since version 2.12, the Wiimote driver is free of any kernel extension or other dependency.


              • #37
                Hi Cam.

                Sorry for the late response (crazy things come all together).

                Thanks for the build. It works.
                I tested in ableton Live and it's perfect. In the other hand with Logic now the triggers function correctly, but it receives notes off cutting the sample triggered, and this is disturbing when you hit cymbals and hi-hats. This is rare to me because if i connect drums trough midi cables the cymbals and hi-hats sounds at larger at sample it is (in Logic).
                Trying to test in Pro tools...

                Last edited by iogurt; 01-22-2013, 09:50 AM.


                • #38
                  Hey iogurt,

                  I'm glad to hear it's better, so the fix will be included officially in the forthcoming release.
                  I am almost sure there's a setting in Logic where you can let short notes last longer (ignore the Note-Off message). You could also use MIDI Pipe to filter out MIDI Note-Off messages from OSCulator.

                  Regarding the MIDI implementation of the GH drums, I guess they are sending MIDI Note-On message only, but I can't verify that right now. Unfortunately there is no easy solution to make the same in OSCulator without breaking compatibilty with other features.



                  • #39
                    Hi Camille.

                    GH drums wireless in Logic it's now working!!

                    I built a small patch in environment window in Logic for split notes on and notes off. This is for live play the GH drums (if you playback from midi track, Logic don't trigger out note off messages).
                    This totally solves the problem with notes off. I hope this help other users that uses logic + GH drums. The attachment is a how-to built this trick.

                    Thanks again Cam.

                    Notes on-off splitter.png
                    Last edited by iogurt; 01-23-2013, 01:10 AM.


                    • #40
                      Originally posted by camille View Post
                      As long as it is wireless it should be ok:

                      check out this post about Band Hero drums (working ok) :


                      Hi Camille, I am unable to access that post, I set up my band hero drum set with garage band and it sounds perfect except for the fact that when I play fast not all the hits I do sound. I think is the same problem that you fixed in this post right? I downloaded OSCulator today so It's the last version and updated garage band today also.


                      • #41
                        Hi Horacio,

                        This link points to an old version of the forum.
                        I think you could adjust sensitivity, but you have to know that even with more sensitive input, you won't be able to play fast all the time. The Band Hero drums were designed to play games, not do actual drumming.

                        The most effective way to adjust sensitivity is to select the message corresponding to the pad you want to adjust, press the Space bar to open a Quick Look window (see the signal), and show the Scalings Page (choose View->Flip to Scalings Page or Command-F). Then, to incresease sensitivity, set a lower value to the Input Max parameter. For example start with 0.6 (instead of 1.0), then try playing with the pad and see if that's better. Repeat for other pads.



                        • #42
                          GH drums wireless in Logic it's now working!! Thanks.