No announcement yet.

OSCulator Plug-in for Logic Pro

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16

    Hey, it seems to work for me in Logic 10.7.7 on current Ventura and M1 Mac.

    What I did:

    - Close Logic Pro
    - Copy the current OSCulator.bundle (v.10.1.1) to: /Applications/Logic Pro Device Plug-ins/
    - Then I started OSCulator
    - Before starting Logic, enable the Rosetta Mode
    - Start Logic, and it found the OSCulator Controller (added it, an so on...)
    - Close Logic
    - Disable Rosetta
    - Start Logic again...
    - Although the icon disappeared and the OSCulator Plugin seems to be disabled (greyed out), it still works!
    - An indicator is, that the ports are highlighted
    - Although, i paused the routing and restarted it again - still works

    Here a screenshot - i got three instances of OSCulator runnig:


    But i did not test how it behaves after a restart of my Mac till now...


    • #17
      Happy to see that you found a workaround that works for you!
      Thanks for the tip.


      • #18
        I tried your trick and indeed, I managed to see OSCulator in the device list in native ( = not Rosetta) mode.
        Alas, in the OSCulator monitor, nothing is transmitted, contrarily to Rosetta mode where all messages are active and shown in monitor.

        I don't know what kind of witchcraft you used, but, congratulations !


        • #19
          No witchcraft - i swear

          i can check the steps exactly for you if you want.
          and write down here.

          but i am not at home today… maybe sunday.


          edit: as far as i remember (not sure exactly)

          - check that the messages work in rosetta mode
          - switch logic to normal mode
          - maybe restart the osculator instance (not close the app)

          try to fiddle a bit - with logic and osculator thats how i did

          no guarantee that its really stable after reboot or sth.

          i do not use this everyday, so thats the reason i dont rememder exactly. But im sure to reproduce when sitting in front of my mac…
          Last edited by guuft667; 05-17-2023, 09:58 PM.


          • #20
            Originally posted by LoicD View Post
            I tried your trick and indeed, I managed to see OSCulator in the device list in native ( = not Rosetta) mode.
            Alas, in the OSCulator monitor, nothing is transmitted, contrarily to Rosetta mode where all messages are active and shown in monitor.

            I don't know what kind of witchcraft you used, but, congratulations !
            just checked again - it works!

            1st Pic in Rosetta Mode:

            After this i closed Logic, disabled Rosetta and started again... nothing else...
            2nd Pic: Non-Rosetta Mode:

            Sure that you copied the current OSCulator.bundle (v.10.1.1) to: /Applications/Logic Pro Device Plug-ins/
            Please check exactly how i described this...


            • #21
              Yes I did it, and actually it works... randomly.
              Sometimes it would pick up OSC messages, sometimes not, without any error messages dropped.
              I'll keep my TouchOSC setup that a tad more annoying but more stable.
              Thanks for your precious efforts


              • #22
                Thanks for the confirmation.

                I can not reproduce any dropped messages in my environment.
                So - i think it may depend on your configuration or network, or.. or.. or..

                But if you are happy with TouchOSC - so far... Have Fun ;-)

                For me - i just learned a few days ago how powerful OSCulatator is.
                Sure, not simple to understand the details. But from day to day, i dive deeper into it and have more ideas how to integrate it in my environment.

                Thanks for such a great tool!


                • #23

                  Sorry for maybe spamming you.

                  I refer to your post:

                  Originally posted by camille View Post

                  I just checked in with Apple about this issue.
                  They told me Logic Pro Control Surface Plugins are no longer supported, and therefore not loaded on Apple Silicon, this is what dnonkong refers to. I would like to replace the OSCulator Plug-in for Logic Pro with a MDS (MIDI Device Script, written in Lua language), but the documentation looks quite sparse at the moment. Once again, a deprecated feature with no obvious migration path…

                  I can exactly understand what you mean. I was trying to build my custom OSC MDS script since about a year...
                  I was searching for documatation about this. All i found was this here:
                  View a table of top control surfaces that Logic Pro for Mac directly supports.

                  Notice this: "To use a control surface with an Apple Silicon Mac computer for which no built-in plug-in is available, consult the manufacturer’s support materials for the control surface to see if an MDS is available."

                  Apple did never publish any further documentation about the MDS scripts, as far as i know. I can not realize why - or what the purpuse is.

                  I also tried to look inside the built in MDS-es. Just to learn how they work... Nothing.

                  Then i found the MDS Script, which Native Instruments offer to their Customers

                  Scroll down and you will find the zip. "MASCHINE MK3 OSC.device" seems to be interesting. I learned a lot from this script.

                  But: If you read the original commeted-out margs from NI:

                  --[[ Requirements for OSC Profiles
                  For OSC Profiles, there are only three functions to be implemented:
                  * `controller_info`: as with any other MIDI Device Profile, provides a default assignment list, just as for other control surfaces, and also the pattern recognizing the device (`OSC_pattern`)
                  * `CSFeedback`: doesn't send any feedback; returns a non-null value for the maximum length of text feedback.
                  * `CSLabelSize`: returns the maximum length of a text label, if there is one for the assignment.
                  All OSC communication is done by Logic Pro — you don't have to write it.]]
                  --- ControlIDs
                  In general the field ControlID seems not to be required for an entry in the Item table, however some entries that seem
                  similar to others will not show up correctly unless they have a controlID assigned to them (e.g.
                  'fader-bank-' and fader-bank+' where only the first entry shows up when both have no ControlID assigned to them).
                  The ControlIDs seem to be arbitrary as long as they are unique.]]
                  NI seemed to be in the same situation... Trial and error...


                  I think it is possible to run MDPs (MIDI Device Plug-ins). Although Apple says no. As i posted here.
                  Sure: "~/Library/Application Support/MIDI Device Plug-ins" is ignored by Logic on M1 Macs.
                  But: If you put it directly into the Logic Apps Dir: "/Applications/Logic\ Pro\\ Device\ Plug-ins/OSCulator.bundle/Contents/MacOS/" it seems to work.
                  And if you look at the TouchOSC.bundle - it is fully supported on my M1 Mac. So the claim "control surface plug-ins from manufacturers other than Apple do not work on M1 Macs" is simply not true...

                  I think that the only "trick" is to compile the bundle with both architectures...
                  x86_64 and arm64...
                  ...and put this into /Applications/Logic\ Pro\\ Device\ Plug-ins/ folder

                  I bet money that it will work

                  Example: Look into the TouchOSC.bundle:
                  lipo -archs /Applications/Logic\ Pro\\ Device\ Plug-ins/TouchOSC.bundle/Contents/MacOS/TouchOSC
                  ?gives me:
                  x86_64 arm64
                  while your OSCulator.bundle:
                  lipo -archs /Applications/Logic\ Pro\\ Device\ Plug-ins/OSCulator.bundle/Contents/MacOS/OSCulator
                  gives me:

                  So... long post - a simple final question:

                  Would it be possible for you to compile the OSCulator.bundle with both archs (x86_64 and arm64)?
                  As far as my own experiences with Xcode: It should not be really hard to additionally add the arm64 arch...

                  don't hecitate to contact me, if i can help out with this.