Announcement

Collapse
No announcement yet.

No messages shows up in OSCulator with Logic Plug-in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No messages shows up in OSCulator with Logic Plug-in

    Hi!,

    Thanks for a great app!

    I'm in latest Logic, latest OSCulator and Mojave and I'm trying to use the Logic plugin. I've added OSCulator in the control surface setup, but nothing is happening in the OSCulator window when I hit play or change tracks or faders. No messages shows up. I've set OSCulator in the control setup ports. What obvious step am I missing?

    I followed the 3-step Logic guide and I got messages to show up with the environment-tweaks, but by using the Logic Plugin, would that eliminate the need for environment changes? I want to use the track focus parameter, but not sure how I would access that in a similar way that the guide was showing for volume/mute etc, so I figured I need to get this Logic Plugin working

    Thank you!
    Last edited by seabass; 11-11-2019, 10:18 PM.

  • #2
    Hi Sebastian,

    What changes did you have to make to the environment?
    You shouldn't need to tweak anything in order to get the plugin working.

    I'll have a look and get back to you as soon as I can.


    Best,
    Cam

    Comment


    • #3
      The tweaks I made are the ones on this page:
      https://osculator.net/doc/tutorial:2:a

      Not a single message popped up in OSCulator until I mapped that in the environment.

      Maybe I’m not understanding this correctly, but I thought that by installing the Logic plugin, I could essentially just hit play or touch a fader and a message would show up in OSCulator, without any environment changes?

      If there is a way to reach the track focus and track name feature the same way as that tutorial is describing I may get around, but it seems like the plugin would do all of that work for me so I’d rather do that?

      I don’t know what else to change here. I went into Logic midi sync settings and clicked around too and the only thing that creates a message in OSCulator was checking the clock checkbox (which generated a clock message), but apart from that, nothing is generating any messages.

      I see that there is an OSC section in the Logic controller assignments window. Is that for input only or is that meant to go both ways?
      I assume not, since OSCulator would not be needed for this then.

      Thanks!!

      Comment


      • #4
        My friend tried it at his place and he doesn't get any messages to pop up either. But we have pretty similar setups, so we're probably doing the same thing wrong. Very grateful for help on this! Thanks!

        Comment


        • #5
          Hi Sebastian,


          I just tested the OSCulator Plugin for Logic Pro X and found no issue when using it.
          My configuration is macOS 10.14.6, OSCulator 3.4.0 and Logic Pro X 10.4.7.

          I had nothing special to do, just follow the instructions in the installation steps.

          I hope you will have more luck going forward!

          Best,
          Cam

          Comment


          • #6
            Thanks! If I'm not mistaken, the issue was that I placed the plug-in in both global and local libraries. I removed it from the global library and restarted the computer and now it works!

            Comment

            Working...
            X