No announcement yet.

"Integrity of this copy of OSCulator has been compromised..."

  • Filter
  • Time
  • Show
Clear All
new posts

  • "Integrity of this copy of OSCulator has been compromised..."


    I've been using OSCulator for a few weeks as I'm developing a custom iPad controller for Logic. I got a strange message tonight that I haven't seen before:

    "The integrity of this copy of OSCulator has been compromised.
    Please download a fresh binary on the website."

    I'm using the latest version (2.10.2) on OSX 10.6.4. All I was doing at the time was entering a bunch of key combos. I tried rebooting, trashing OSCulator prefs, etc., and it keeps happening at random.

    Any idea what would cause this?

    Thanks in advance,
    Jim Daneker
    Film & Trailer Composer

  • #2

    Have you tried to download from and reinstall the application as asked in the message?
    There is a possibility that an automatic update has failed at some stage. You will be better off downloading the application again anyway.

    Last edited by camille; 10-20-2010, 10:47 AM.


    • #3
      I figured out what was causing the problem. I had Logic open at the same time as I was editing in OSCulator, and of course Logic automatically created a control surface for OSCulator. Usually I delete that control surface immediately but I forgot to in this case, so the two apps were conflicting.

      I did reinstall OSCulator just in case, and everything is fine now.

      Jim Daneker
      Film & Trailer Composer


      • #4
        How weird, does that mean that Logic changes the contents of Osculator while opened?
        I will have a check.


        • #5
          Well, the plot thickens. I'm not sure what's causing this, but it keeps happening at random. When it happened yesterday, I was running off my backup system so I could try Logic 9.1.2 (I'm in the middle of a major concert tour so I can't take chances with my main rig). Anyway, it started happening tonight on my main rig which is still running Logic 9.1.1 and the latest version of OSCulator.

          After a fresh boot, here's my startup sequence:

          1. Create a private Airport network on the Mac and link to that on my iPad/phone
          2. Open OSCulator and load my show file
          3. Open TouchOSC on the iPad & confirm communication
          4. Open Logic and immediately delete the control surface it detects

          At that point things are usually rock solid, but after a few minutes I got the "OSCulator compromised" message and it shuts down.

          I tried trashing all relevant preferences, rebooting, etc. and nothing helped - it kept happening. Nothing seemed to trigger it - it would just pop up at random even while idling.

          So, something is corrupting OSCulator (or causing it to think it's corrupted anyway). Any help appreciated!

          Jim Daneker
          Film & Trailer Composer


          • #6

            I am sorry that it happens to you.
            You are the first user that tells about this issue.

            Each application on a Mac is actually a directory with a ".app" extension.
            There is something on your computer that changes the contents of that directory. I am almost sure that it has nothing to do with the Logic control surface. I use Logic quite often, and Logic doesn't change any bit of another application.

            Three questions:
            • Where is the application located on your hard drive?
            • Are you sure you have only one copy at one location (/Applications)?
            • Could you please zip the faulty application, and email it to me?

            Here is something you can do:
            1. Open Disk Utility (located in /Applications/Utilities)
            2. Repair authorizations for the startup hard drive.
            3. Download (again!) OSCulator from the website, and copy the folder to /Applications

            Please let me know if that works for you.


            • #7
              Hi Camille,

              The app is in its default location (Applications folder > OSCulator ƒ). I did do one thing that may be a factor: after I finished creating my rather lengthy list of key combos for Logic, I dragged a copy into the Resources > KeyCombo Sets folder within The OSCulator app itself ("show contents...") so I could get to it faster via the defaults menu. Was that a bad move? That's the only thing I've done that would make it different from a factory install, but I wouldn't think that would have an effect on communication since it's just a preset file?

              I'll reinstall a fresh copy again and leave it alone this time ;-)
              Jim Daneker
              Film & Trailer Composer


              • #8
                It's a good idea to be able to add more file in the Key Combo menu, I'll add the possibility to add more KeyCombo files in the ~/Library/Application Support/OSCulator/Key Combos folder for the next release.


                • #9
                  That's great, thanks Camille. Your support here is much appreciated!

                  So, was adding the file manually to the app's resources folder a bad idea? I'm just curious as to the technical reasons if so. I've done a fair bit of similar tinkering with other apps and never seen anything like that before...

                  Whatever the case, it seems to be working again after a fresh (unmodified) install ;-)

                  Thanks again for your support - this app is a HUGE help!
                  Jim Daneker
                  Film & Trailer Composer


                  • #10
                    Thanks for the kudos :-)

                    The first reason why you should not change the contents of an app's bundle is technical. Many Mac software, like Osculator, use Sparkle to manages updates, and when the application is updated, it is replaced with the ne application bundle, which means that you could lose the changes you have made.

                    The second reason is about copy-protection. The application has been suffered from piracy 3 times last year, and locking the application contents is one another way of protecting my work, and be fair with honest users that paid for this work.

                    Before I add a way to add user defined folders for Key Combos, you can still drag and drop a file on the Key Combo table. It has the same effect as using the "Import ..." menu item, but is surely not as quick to access …


                    • #11
                      Ah - all good points; thanks for the clarification. Glad I paid for my copy - I already feel like I owe you more ;-)

                      I'm going to spread the word among my composer friends about all that can be done with TouchOSC & OSCulator - I don't think most people are aware of the possibilities. The fact that it can trigger standard keyboard & mouse events, Applescripts, etc. *in addition to MIDI* is simply awesome... truly exciting stuff. I'm doing a seminar in November for Logic-based film composers, and I'll be sure to add a whole section highlighting OSCulator as a component to building custom controllers. Hope that sends some business your way!

                      Thanks again,
                      Jim Daneker
                      Film & Trailer Composer


                      • #12
                        Hi Camille, and thanks for your question whinecellarstudio.

                        I purchased your software a few years ago.
                        I am also getting this new message.
                        Is it possible that this happened when I migrated all my software to my new Macbook Pro?
                        However, I am not sure what actually happened.

                        I am fine to reinstall Osculator, but am concerned I will loose the configurations my technical collaborator set up.
                        Is there a way of saving the file or configurations before doing this?

                        Many thanks,


                        • #13
                          ... alternately, if you think it is something else, I would appreciate your help, Camille.



                          • #14
                            Hi Teresa,

                            This message is displayed when the contents of the application bundle has been modified.
                            This happens when:
                            - you add, remove or modify a file in the bundle.
                            - or use system optimization tools like "MacKeeper" or "Clean My Mac". They offer to gain disk space by removing what's unused on your computer, like app translations in language you don't need, or remove "universal" and "32 bits" code. I don't recommend the use of these tools on a general basis.

                            Unless you have modified the "Samples Library" folder, you can just replace the whole "OSCulator ƒ" folder. The application stores your license and its settings in the Library located in your home folder. Make sure you backup the documents you created though, it's always a safe practice.

                            Please let me know if downloading OSCulator fixed this issue.



                            • #15
                              Thanks so much Camille. Almost there. Reinstalling got rid of error, but now Osculator is no longer talking to my MaxMSP audio patch.
                              I've been trying to set Osculator the same way I had it before, but there is one screen that doesn't offer the same setting as before.

                              I am attaching the before and after versions in case you can see what I am doing wrong.

                              Many thanks in advance.


                              Screen Shot 2015-04-14 at 3.10.41 PM.jpg

                              Screen Shot 2015-04-14 at 10.36.46 PM.jpg