Announcement

Collapse
No announcement yet.

Choose Only Bars/Beats from Logic's Beats Clock Format

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Choose Only Bars/Beats from Logic's Beats Clock Format

    I'm able to display Logic's beats and SMPTE in TouchOSC using OSCulator. I'm happy with the SMPTE display, but the beats jiggle around too much. Logic essentially has 2 main clock formats: "bars beats subdivisions ticks" (1 1 1 1) or "bars beats ticks" (1 1 1), with various alternates with or without periods in between the numbers, etc. The latter jiggles around less, so that's what I'm using in the below example. However, I don't want to see ticks. I assume Logic is sending a string of numbers and spaces to OSCulator, which I'm sending to my Android phone.

    Is it possible to filter the clock format even further so that I only see bars and beats in TouchOSC?

    I tried sending only argument 0 or only argument 1, but I get the same result as sending all arguments.

    TouchOSC doesn't allow text alignment within a label (as far as I can tell). Resizing the width of the label isn't an option as "bars" could be anywhere from 1 to 3 digits.

    I notice that when I double click on <all args>, it turns into $args. Is there something fancy I can do in here to modify the output? If I'm able to use regex, that's great, but am open to any solution that gets the job done.

    Thanks for any help.


    giphy.gif
    Logic Pro X 10.3.3 | OSCulator 3.4.1 | TouchOSC 1.9.10-a2 | TouchOSC Editor 1.8.7 | Mac Pro 5,1 2009 | OS X El Capitan 10.11.6
Working...
X