No announcement yet.

OSCulator doesn't see my iPad

  • Filter
  • Time
  • Show
Clear All
new posts

  • OSCulator doesn't see my iPad

    I'm trying to configure my iPad for two-way communication with OSCulator and there is a problem with Bonjour. TouchOSC on the iPad sees OSCulator on the Mac, but OSCulator doesn't see TouchOSC on the iPad: TouchOSC does not appear in "Nearby hosts", even though it's running and connected.

    I've tried different combinations of OSC implementations and I always get the same result, which is why I think it's more related to Bonjour than to OSCulator. But since you must have played a lot with Bonjour and tested OSCulator in a lot of different setups, I thought you might have an idea where this comes from.

    Has anyone managed to detect the iPad automatically from OSCulator?

  • #2

    Hi Sébastien,

    This sounds to me that your wireless router is not acting properly, or that you should restart computer if you are running Leopard (10.5). A firewall could also be the source of the issue.

    Could give us some details on how you connect your iPad to the wireless network?

    Like you said, the networking code has been tested a long while ; the 2.10 version brings a slight bump ofreliability on that area.

    I would not rule out the possibility of a bug though, but this is unlikely from the description of your problem.



    • #3

      In fact, after further investigation, I tested it with Bonjour Browser and it can see OSC servers on others computers on the same network, but not other iPads. So I think the problem comes from Bonjour on my iPad. I've tested it on 2 different networks and the result is the same. I'm starting to wonder if the problem doesn't come from the fact that my iPad is jailbroken. I'll try to restore it to see if I can reproduce the problem.


      • #4

        I don't know if it is because I have restored my iPad to remove the jailbreak, or because something else has changed in my set-up, but now OSCulator can see TouchOSC on my iPad. But it still cannot see my own iPad application. So I guess my problem comes from the OSC implementation I'm using in my own iPad application. I'll try to change it to see if it works better.


        • #5

          What implementation of OSC are you using?


          • #6

            I'm using VVOSC. But eventually I found the problem:

            It works great now.