No announcement yet.

No signal back from Ableton to OSCulator

  • Filter
  • Time
  • Show
Clear All
new posts

  • No signal back from Ableton to OSCulator

    Hi, I'm having trouble with the two way communication. I use Ableton Live 7.0.18. I can get the signal to Ableton live but I can't get it back to OSCulator (i.e. /midi/cc29 & xy-controller) & TouchOSC. OSCulators status leds and TouchOSCs red indicator don't blink.

    Also if I move the mouse in Ableton (i.e. Phaser which has xy-controller) key/midi out indicator in Ableton blinks but does not go back to OSCulator.


  • #2

    Hi Slatva,

    I need to know a bit more about how you have setup everything.

    What version of OSCulator are you using?

    Also, have you followed the steps to setup Live?




    • #3

      Hi, I'm using 1.6.1 version of OSCulator. And yes I have followed the tutorial steps.




      • #4

        Hey Slatva,

        I think you must be referring to TouchOSC 1.6.1.

        Could you please check your version of OSCulator, and give a little more details on what you did to setup Live and OSCulator?

        If OSCulator doesn't receive MIDI from Live, there must be two reasons :

        1- the OSCulator document you using is locked, check if you have a small lock icon on the top right of the window. If this is the case, unlock the document by pressing Command-L.

        2- Live MIDI preferences are not set correctly, and MIDI is not sent to OSCulator. In Live's MIDI preferences, make sure that the Remote column is checked for the device "OSCulator In (xxxx)" where xxxx is the OSC input port of your OSCulator document. It is usually set to 8000.




        • #5

          Hey, sorry about the confusion with the names.

          Anyway OSCulator version is Version 2.10.2 (20100917).

          I use Simple preset from which I map xy to Abletons Phaser. Live receives these messages and probably sends (because the MIDI out indicator blinks) but OSCulator doesn't receive these messages.

          1. I unlocked.

          2. checked the preferences.

          But unfortunately this did not help.

          If I click manually the little box in OSCulator OSCrouting red light appears in TouchOSC.

          Here are screenshots of my live preferences and osculator:

          Hope I have provided enough information.

          Once again thanks,



          • #6

            ok, thanks for the details.

            The red les means that OSCulator can't find your iPad.

            If you are running Mac OS X 10.5, you will need to reboot your computer. This should solve the problem.

            If you are not running 10.5 or if the problem perstists it means that you have network connectivity problem. Try connecting your iPad directly to the computer using an ad-hoc network (check out he FAQ on this site to see how to do this).

            Other than that your file looks fine and it looks like OSCulator receives MIDI from live correctly but is not able to send it to your iPad.




            • #7

              hey, i tried booting and ad-hoc network, but still no signal back.



              • #8

                Strange, it should work flawlessly.

                If you follow the tutorial instructions carefully, there is not much to do.

                If the FAQ, there is an item about bi-directional communication. It says that you can try to remove all message starting with /midi and let OSCulator re-create them.

                This is maybe the source of your problem, and I forgot to ask you this question.

                If this doesn't work, I think I'll be out of ideas, sorry !!!


                • #9

                  Finally got it working. I created an empty file and let OSCulator create all routings. Of course I need to build every setup myself, but at least I got it working.