Announcement

Collapse
No announcement yet.

OSC feedback ? Ipad + Mac + Traktor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OSC feedback ? Ipad + Mac + Traktor

    OK, here's my pb:

    My setup, right, now, is controlling Traktor. Fine.

    But I wanna add duplex communication. I want my buttons to light on when they're on, and off when they're off. I want my buttons/faders/etc on my ipad to follow if I move them directly (with my mouse) on Traktor.

    For the buttons, I'm just adding a MIDI OUT in traktor on the same CC channels. OSCulator routes it back to the ipad, it works great.

    The pb is the faders. Mine are relative, most of the time, to avoid touching one by mistake... while trying to touch another one, of course.

    When I create the MIDI OUT from traktor (anc back to the ipad with OSCulator) it just makes my faders act epileptic ! It seems to me, when I move a fader on the ipad, that the information goes down to traktor, then come back to the ipad, then goes down again to the traktor... etc...

    I just need the information to go from the ipad to traktor and back !


    If they are ABSOLUTE, it's not a pb.... but absolute fader, in my situation, are just too dangerous !


    If someone got any idea, I'll take it. maybe it's a feature request ? I don't know... as I'm not sure the reason why.

  • #2
    Hey krr,

    Absolute or relative is only affecting the way the control reacts to touch.
    Value positioning is the same wether the fader is absolute or relative.


    Cam

    Comment


    • #3
      damn.. I know my description isn't clear.

      here's a video that shows the pb:
      http://www.youtube.com/watch?v=kz9Au2ZU23U

      Comment


      • #4
        ok, I got it.
        your video shows very clearly that there are two problems involved :
        1. Traktor sends back values as it is updated. (for me it is an error if an endpoint, here Traktor, sends back a value when it is not the originator of the change.)
        2. TouchOSC continues value tracking as the finger is in contact with the screen.

        One solution you could use is to enable /z messages in TouchOSC, and use a Enable message in OSCulator to disable your fader's update from MIDI.
        The steps :
        • enable /z messages in TouchOSC (check out the settings screen)
        • touch your fader
        • assign to this fader the Event Type "Enable" and the Value "/midi/cc28/11"
        • touch again your fader, the message /midi/cc28/11 should be disabled
        • click on the enable checkbox (first column) to enable the /midi/cc28/11 message when the fader is not touched (and disable it when it is touched).

        All of this is a big hack, but you wouldn't need to do that in the first place if Traktor was not sending spurious values updates like this, or if TouchOSC was not paying attention to new values when the finger is pressed. If you have a look at Traktor, maybe you could find there is an appropriate option.


        Best,
        Cam

        Comment


        • #5
          OK, I can't try it now, as I'm @ work, I'll do ASAP.

          in fact, I need to be in relative mode: to change something in relative mode, one needs to "move" fingers while touching the screen. In absolute, a single touch is enough to change the value: I think it's dangerous especially when you got a lot of controls at once on the screen. Relative is safer...

          The ouput "back" from traktor is need to update the fader position when there's something else than the ipad that change any fader or pot value: automatic reset (I sometimes use it), or double click to reset a value to zero (I often use it).

          here's why I'm doing/needing this. Anyway, I'm gonna try your solution and will keep you informed.


          Anyway, great piece of software and nice support. I like that and will let it know to my students (:

          Comment


          • #6
            great. got at last enough free time to give a try again.. seems your "hack" is working... this means a lot work to make it properly work but it seems to work... at least with one fader (: I'm gonna build my setup and give a try with a mix on traktor.

            Comment


            • #7
              Originally posted by camille View Post
              ok, I got it.
              your video shows very clearly that there are two problems involved :
              1. Traktor sends back values as it is updated. (for me it is an error if an endpoint, here Traktor, sends back a value when it is not the originator of the change.)
              2. TouchOSC continues value tracking as the finger is in contact with the screen.

              One solution you could use is to enable /z messages in TouchOSC, and use a Enable message in OSCulator to disable your fader's update from MIDI.
              The steps :
              • enable /z messages in TouchOSC (check out the settings screen)
              • touch your fader
              • assign to this fader the Event Type "Enable" and the Value "/midi/cc28/11"
              • touch again your fader, the message /midi/cc28/11 should be disabled
              • click on the enable checkbox (first column) to enable the /midi/cc28/11 message when the fader is not touched (and disable it when it is touched).

              All of this is a big hack, but you wouldn't need to do that in the first place if Traktor was not sending spurious values updates like this, or if TouchOSC was not paying attention to new values when the finger is pressed. If you have a look at Traktor, maybe you could find there is an appropriate option.


              Best,
              Cam
              I came back two hours ago to my set up...; to finish it. For some reason, I can't use your trick anymore: I can't enable anything from /Z message to /midi/ .... Osculator only allows me to enable it to the OSC values which are already in my setup.... ? got an idea ??? I would like to use it on stage tomorrow nite....

              edit: damn.. it came back.... what did I do ??? argghh .. this is an unbearable feeling.. to solve something without understanding what you just did to solve it... -_____-'
              Last edited by krr; 04-23-2011, 08:37 PM.

              Comment


              • #8
                Ok, As I'm working on my iPad/Traktor setup, I've tried it... and noticed that when I push the Cue or CueP button, the tracks doesn't start all the at once... I guess this is because there's latency on wifi.... plus time for osculator to translate things.

                is there a way to avoid it ? I've tried on my freebox wifi (the one I use all the time for internet access), I've tried my Airport Express (which is not connected to internet and with only the laptop and the ipad connected.. to avoid any kind of interference)... in both case, random lantecy.

                is it possible to have a direct access using USB ?? or is it too hard/long to program ?

                maybe it's possible using MyWi... but I need to jailbreak my ipad... (and dont really want that right now for several reasons....)

                Comment


                • #9
                  If you can not configure an event with a /midi/xxx message, the only obvious reason I see is that you have not received any MIDI message yet, and therefore there is not message to use in the list.

                  Comment


                  • #10
                    Sorry USB is not possible unless you use MyWi an jailbreak your iPad (see that post http://www.osculator.net/2010/07/19/...sb-connection/).

                    The best way to connect an iPad to a Mac on stge is to use a small Wifi to Ethernet router that is plugged to the Mac. An Airport Express will do, but don't connect you Mac wirelessly.

                    The freebox is one of the worst wireless router, don't use that.

                    FYI OSCulator virtually takes no time to process the messages, the only latency you can observe is caused by the wireless network.

                    Comment


                    • #11
                      Originally posted by camille View Post
                      Sorry USB is not possible unless you use MyWi an jailbreak your iPad (see that post http://www.osculator.net/2010/07/19/...sb-connection/).

                      The best way to connect an iPad to a Mac on stge is to use a small Wifi to Ethernet router that is plugged to the Mac. An Airport Express will do, but don't connect you Mac wirelessly.

                      The freebox is one of the worst wireless router, don't use that.

                      FYI OSCulator virtually takes no time to process the messages, the only latency you can observe is caused by the wireless network.
                      OK, I note that MyWi is a way... but it's not something one can use everytime: sometimes you need to upgrade your iphone/ipad to a newer OS which is not yet jailbroken. As my iPad is used for pro purposes, it happens.

                      I tried to setup a wireless network FROM my laptop but no way.

                      the airport express seemed to have the same latency as the freebox... but of course, it's only how it seemed... i'm sure the airport got a less latency.

                      too bad, I've built one of a hell of a layout for traktor... and I'm gonna change it again cause i'm gonna stick to my faderfox controllers for controls that need a instant response... and send all others on the ipad.

                      ----

                      About my previous post, I'm not sure ... I think there were midi msgs received... but not sure. Anyway, as I'm gonna spend some more hours on my setup, I think I'll come thru the same pb eventually...

                      Comment


                      • #12
                        aaaaannd another pb coming:

                        now that I have a /z msg that are activated.... they seemed to parasite the way push buttons are reacting -___-' ...

                        I 've run several tests, and it seems that sometimes, pushing the buttons only send /z msg...

                        as shown in OSCulator, I now got two lines...
                        for instance, one is /1/FilterOnB to control the filter ON push button of the second deck, and the other one is /1/FilterOnB/z ...
                        they both have LEDs to their left to monitor when they're activated. One yellow for /z and green for the main one.

                        when I touch the push button, on my iPad, lets say, four times in 2 seconds: first time, ok, both leds light in the same time. second time, the yellow led lights half a second and then the green one. weird ? three times: ok again. four times: only the LED of the /z msg turn to yellow... the green led of the "main" stays off. and of course the MIDI message isn't sent.

                        I tried to turn on and off the local feedback in touchOSC layout... doesn't seems to bypass the pb. idea ?

                        sorry to flame the forum... I'm reporting my tests "live" (:


                        EDIT: I've noticed that traktor only received the first message from the "four times" touch...


                        EDIT again: aaaaaaaaaaaaaaaaahhh. I get it. it seems it's because I changed my Event Type from MIDI CC to MIDI CC Toggle. argh. .... back to MIDI CC for everything.
                        it seems to work better and it increases the reaction. the latency is lower ! not low enough for narrowed accurate mixing on indoostrial stuff but I'm back on freebox for my tests. I'll try with the airport asap (:

                        (I made the questions and the answers... arf.... anyway, maybe it will help someone who will go thru the same thing.. after me...)
                        Last edited by krr; 04-23-2011, 11:50 PM.

                        Comment


                        • #13
                          That's definitely a networking problem.
                          If you are using the freebie as a router please try something else.
                          Remember that I said that the Airport Express base must be plugged with Ethernet on the Mac.

                          Comment


                          • #14
                            Originally posted by camille View Post
                            That's definitely a networking problem.
                            If you are using the freebie as a router please try something else.
                            Remember that I said that the Airport Express base must be plugged with Ethernet on the Mac.
                            nope dude.... it was my mistake, using Midi CC toggle instead of basic MIDI CC. I've just tried my basic setup and it works like a charm... of course, I need the automatic beatmatch from traktor to help me, because the latency wouldn't allow to beatmatch properly... but except that, even on the freebox, it works really fine. (<= one happy customer)

                            btw, I bought a OSCulator licence as you may have noticed.... It's gonna work tomorrow evening in the rockstore@montpellier... electrorock in yer face, baby !

                            Comment

                            Working...
                            X