No announcement yet.

TouchOSC talks to Logic Pro but Logic doesn't talk back

  • Filter
  • Time
  • Show
Clear All
new posts

  • TouchOSC talks to Logic Pro but Logic doesn't talk back

    Hey folks. I inherited an iPod Touch 2G and it's running iOS 4.2.1. I've got TouchOSC and OSCulator talking to each other over a network that only exists between my MacBook and the Touch. I've spent several hours today trying to get TouchOSC and OSCulator to play nice with Logic Pro 9 and I hit a snag. So far I am excited about the possibilities and plan to register as soon as I get things firing on all cylinders.

    I've gotten as far as getting faders on the Mixer screen in Logic to mirror movements on page 2 of the Mix 16 layout in TouchOSC, which I find very entertaining and downright magical! However, I cannot get Logic to send feedback to TouchOSC. I did all the cabling in the Environment window, the monitors work, etc. and the first time I moved a cabled fader, I did get a message in OSCulator quite similar to what I should have. For whatever reason, there was no feedback sent from Logic and the subsequent faders did not send messages.

    Am I missing a step? Does feedback only work in iPhone and iPad? My thanks in advance to anyone who responds. I am looking forward to minimizing mouse based control of Logic!

  • #2
    Hi Skincage,

    iPhones, iPads, and iPods Touch should all be working the same.
    No problem on that side!

    It seems you are following this tutorial (, is that right?
    Can you tell exactly where you have gotten so far in this tutorial?
    Do you see any activity received in OSCulator when you move a fader?

    It will be difficult to locate the problem without more information, so I'd suggest you send your logic and osculator files to my email camille at osculator dot net.

    Bi-directional Logic setup is not easy, and this is why the tutorial is rather lengthy (but it covers also a lot of different areas!).



    • #3
      I am following that tutorial. I'm up to the point quoted below:

      "Moving the Audio 1 fader will create a new item in OSCulator. Try to move the fader in Logic Pro, and a new event will be created in OSCulator:

      Now, move the fader again, and you should see this action reflecting on the iPhone."

      That first event was created, and it lights up when I move the first fader, but I can't get any further entries to be made for additional tracks even though I seem to have duplicated the cabling and Transformer settings.

      For what it's worth, the TouchOSC->Logic control is very quick and seems stable, it's the other end that's giving me gruff.

      Thank you for your response and assistance.


      • #4
        Hey Skincage,

        OK so I think I have found the origin of the problem you were having.

        OSCulator scans the network in order to find potential OSC destination.
        For example, TouchOSC, or any OSC device that publishes its information on the network.
        It turns out that OSCulator also uses Logic as a OSC destination. It is not technically incorrect, but practically useless, and in your case it leads to confusion.

        The workaround is to open the Parameters Window, and go to the OSC tab.
        Now change the default target to your iPod Touch by setting the radio button to the correct position.
        In my case, it was the second row. The first row was merely the name of my computer (which I knew was the OSC service published by Logic).

        I will fix this sort-of-bug by ignoring Logic's OSC service in the latest beta.



        • #5

          Thank you for your assistance!

          I tried the workaround, but the iPod doesn't show up in the window. I see only my computer name. At this stage I have the same level of control but no feedback. Is it possible I need to change port settings?

          Also, in Logic, I get this error. Perhaps I need to tweak something within Logic?

          'OSC device "univac:8000 (OSCulator)" uses Port 8000 which is already used by OSC device "univac:8000 (OSCulator)".
          Enter a different incoming port in the network settings of "univac:8000 (OSCulator)"

          If you have further suggestions, I'd love to try them. Might I be better off to wait for the beta?

          Thank you.



          • #6
            Hi !

            Don't worry there is nothing wrong with Osculator, have you tried what was suggested in Logic's message?
            Here is a discussion I recently had with the same problem:

            If your iPod doesn't show up in the window, first try to reboot it and your computer.
            If you still don't see it, please tell me :
            - what are the versions of Mac OS X and iOS on your Mac and iPod?
            - how you connect it to your computer (computer-to-computer network, or using a wireless router)
            - is there a firewall running on your computer?



            • #7
              I can't seem to get the iPod to appear. The only change so far was that my computer name appeared in red rather than in black.

              My Mac OS X version is 10.6.7
              My iOs version is 4.2.1
              I connect via a computer to computer network, and the firewall is disabled.

              I tried a reboot of both devices to no avail. I tried changing the default port to 9000 but this caused me to lose the unidirectional control that I had. Putting it back to 8000 and restarting both programs restored it but placed me back at the point where I began to write you.

              I assume from my basic knowledge of midi that I should always open the master (OSCulator) before the slave (Logic), is this correct? I am wondering if maybe my port selections need to be a little more informed. I picked 9000 for the default in OSCulator. In TouchOSC I picked 9000 for outgoing and 9393 for incoming. Do they have to be formatted a certain way?

              Thanks again for your continuing help! I wish more developers had your attitude.



              • #8
                Hey Jonathan,

                Thanks for the nice words.

                If you change the input port of OSCulator, you need to update the configuration of your TouchOSC.
                This is because TouchOSC doesn't track properly the port change (although in a perfect world, it should).
                Sorry, it seemed obvious to me so I didn't mentionned that detail.

                You don't need to start one program before or after the other, Logic is properly notified of the presence of OSCulator before or after it is started. (I believe you are mentionning slave programs like Reason or Live, but in terms of ReWire protocol.)

                There are several problems at once that we need to sort out.
                First of all, there was this problem with Logic being the default target.
                This has been solved, now it should not be in the list anymore (or at least, it should be red, but you can clear that).

                The second issue, is the one that someone elsa had previously :
                When OSCulator is started before Logic, if Logic uses the same input port as OSCulator, a conflict occurs and Logic does not know what to do. Two options here : change Logic input port (mild difficulty) or OSCulator's input port (easy), better use another default input port in the preferences, and change TouchOSC's preferences.

                What bothers me is that you say that you don't see your iPod in OSCulator's Parameters Window (OSC tab).
                Maybe there is something I missed in your description.

                Look at this screen, this is what I have when I launch TouchOSC on the network.

                OSC targets.png

                Let's sort that problem first, and we'll go back in order to the beginning of this thread.



                • #9

                  OK I am going to write down all I did this time around.

                  I created a network between my MacBook and my iPod. Does the channel of the network matter in this situation? The two devices seem to recognize each other.

                  I rebooted both (Mac first), and tried again with OSCulator set back to 8000 as the default port. TouchOSC input port is set to 8000 and the output set to 9000 as in the tutorial.

                  I loaded the existing "logic" file in OSCulator.

                  I went to preferences in OSCulator and tried to find my iPod, but all I see is the name of the network, in red, at slot #1. I have nothing at any other slot.

                  I opened up the template file with the tutorial's settings in Logic. It receives fader movement data from TouchOSC and echoes it on-screen.

                  Moving the fader in Logic does not create feedback to TouchOSC, but it does create the line "/midi/cc6/1 OSC Routing (symbol)->/2/fader1" as it says in the tutorial. However, moving it the second time does not induce feedback and moving faders 2 and 3, which I also set up with the Transformer/Monitor do not create their own lines in Logic.

                  For experiment's sake I closed everything and changed the ports to 5000 in OSCulator, and 5000 in, 7000 out in TouchOSC. I reloaded the files, and I have precisely the same situation. TouchOSC transmits but does not receive. Logic receives but does not transmit. At least, that appears to be so.

                  If you have any ideas, I'm certainly open to further experimentation. I supposed if I had to I could just map my faders to knobs on my AKAI MPK25, but I'd so much rather use TouchOSC! I am not sure what else to try regarding the iPod not showing up.

                  Thank you again.



                  • #10
                    Hi Jonathan,

                    As suggested in a previous post, you should see your iPod in the OSC targets. If you don't, there must be a problem with your iPod.

                    From what I understand from your detailed report, everything sounds fine to me, except that you should not need to assign port numbers manually. Instead in TouchOSC's Network Settings, you should see a line corresponding to OSCulator running on your computer, and tap this line to automatically configure TouchOSC. If you don't see that either, then there is a problem with the network.

                    For what is worth, if OSCulator input port is 9000, then TouchOSC's output port must be 9000 and any other number for the input will do.

                    Also, something that may be confusing is that TouchOSC only appears on the network once the layout is displayed, not as soon as the application is launched. Therefore, to check if OSCulator "sees" TouchOSC, you must launch the layout on your iPod first, then open the Parameters window (then the OSC tab) on OSCulator next.

                    If OSCulator is unable to see TouchOSC on the network, it won't be able to send messages back. I'm surprised that after reboots of both devices, TouchOSC is still not recognized, hence my feeling that something must be wrong with the iPod...