No announcement yet.

FAQ: Connecting Wii devices using OSCulator 2.12+

  • Filter
  • Time
  • Show
Clear All
new posts

  • FAQ: Connecting Wii devices using OSCulator 2.12+

    I've recently had some questions from users about the new pairing process in OSCulator 2.12+.
    Those who were using several devices were confused by the fact that a connected device is disconnected when another is being paired.

    For example:

    I'm trying to use both a wimote and a balance board at the same time with MAX. But no matter what I do with the ports and channels, Osculator always seems to close one or the other as soon as I pair.

    Is there some simple step I am failing to do?
    You must consider the pairing and the connection as two separate operations.

    1- First you pair the devices, it's ok if one device is disconnected when the other is paired.

    You have to do this only once, that is, the red button is only used when pairing with the computer, after that you don't need to do that operation again. You can then proceed to connecting your devices.

    2- To connect a device simply press a button until it connects to your computer. You must not press buttons 1&2 simultaneously because the device goes into a special mode (and does not try to connect to the paired computer). Same goes for the Balance Board, simply press the main button a few times until it gets connected.

    I understand this can be confusing when compared to previous versions of OSCulator, but the connection process is really simple, and most importantly this connection process is future-proof and more reliable.

    Another issue that often arose recently was for users upgrading from OSCulator 2.11 (or earlier) to 2.12. The Perfect Pairing extension is now gone, and has been replaced by an optional kernel extensions that solely deals with the Virtual HID Joystick (nothing to do with the Wiimote anymore).

    A typical example is:

    Hello! Although your page says it supports Mac OS 10.8 Mountain Lion, I am having issues with pairing the Wiimote. Although it says paired, the lights still flash and there are no values incoming. Hope this get fixed soon!!!
    (Regretting upgrading to 10.8 at the moment)

    Have you upgraded the kernel extension when OSCulator 2.12 has first launched? If you are unsure, please go to the Preferences window, then click on the Output tab and uncheck the "Install Virtual Joystick kernel extension" checkbox. Then restart your computer. This kernel extension is no longer needed to connect a Wiimote, and interferes with newer version of OSCulator.