No announcement yet.

Motionplus issues not sending exact data

  • Filter
  • Time
  • Show
Clear All
new posts

  • Motionplus issues not sending exact data

    Hi there.

    Granted i havent been using osculator very long so please bear with me.
    Im using a Wii with motion plus, and connecting it to ableton live to control parameters.

    Ive noticed that without the motionplus, pointing the wiimote up will cause the number to go to 127 and pointing down 0 etc ie there are no perfect calibrations, almost like an on off switch.

    So i got the motionplus, and it connects sweet, and when i hit quicklook it gives me a perfect readout of its angle (in this case, pitch)

    But when i connect it to ableton (continuous control) its acting like there is no motion plus, and as soon as i tilt it slightly up its sending it straight to 127

    any help would be appreciated, im doing an alnighter for a design project due tomorrow at uni so i am in love with anyone who can help me.


  • #2
    Hi Jim,

    It looks like you are having a scaling problem.
    You should check if the scalings have not been changed incidentally.

    If you are using the latest version (2.10):
    1. Locate the "pitch" message and check that no event is assigned,
    2. Go to the scalings page (choose View > Flip to Scalings Page) and look at the values for the pitch message. You should read input min = 0.0, max = 1.0, output min = 0.0, max = 1.0.



    • #3
      Hiya Jim and Cam. I've also had the same problem in the past, and although it frustrates me a lot whenever I run into it and I haven't figured out a solution, I was able to pinpoint it closer than ever tonight.

      I had this .als file going in Ableton Live and I was happily tinkering and testing. I did some more tinkering, what exactly I don't know, and suddenly the pitch tracking behaved as described above , i.e. instead of the assigned value being one-to-one with the angle of the controller, it would fail to measure any value besides 0 or 127 and would instead slip and slide all over the place, eventually ending up at 0 or 127.

      At this point (after flailing and cursing) I started a brand new .als file, and began to piece together something a little like what I'd had before to see if I could reproduce the moment when things went haywire. I couldn't, and the pitch tracking worked just fine, but when I switched back to the original .als file the pitch tracking went bad again.

      Things I definitely checked and verified to not be the problem: type of input (I tried pitch, roll, and yaw) and scalings in OSCulator, midi mapping min/maxes and device mapped to (again, various different virtual knobs tried) in Live, and overuse of the same CC and/or channel. None of these variables had any effect on the nasty "sliding" effect.

      Jim, just so you know, you can totally get one-to-one tracking without a MotionPlus adaptor. My guts tell me this is just a shortcoming of Live. Cam, if you wouldn't mind I'd be happy to email you the .als files and .oscd file.


      • #4
        Yes please Joel, send them over, I will have a look.


        • #5
          Thanks for the quick reply Cam! I'll send them now.


          • #6
            After emailing back and forth with Cam and not really finding any definitive answers, I may finally have hit upon something solid. Please bear with me. This is going to get detailed.

            I opened up my problematic .als file in Live, turned off everything except pitch tracking on Wiimote 1, and changed the pitch of the Wiimote back and forth to see if it motion sensing was still all wrong as described above. It was. I then opened up MIDI Map Mode in Live and clicked on the value my Wiimote's pitch was currently modifying (in this case it was the pitch value in a grain delay effect). When I did so, I noticed something I never had before: in the status bar at the bottom of Live, the message "Mapped to Channel/CC: 1/0 Mode", with a drop down menu just to the right of it. The menu mostly displayed the word Absolute, but kept flashing back and forth to something else: Relative (BinOffset). I pulled out the Live User Manual and looked this up, and what I found out in a nutshell was that Relative (BinOffset) mode would be terrible for measuring the pitch of my Wiimote and would likely produce that godawful sliding effect. Moreover, Live autodetects which mode to use for each CC based on what it can detect from the input device (which is probably fine for almost all devices), and worst of all you can't opt for it to *not* autodetect the mode. As far as I can tell at least; please, *please* tell me I'm wrong.

            I tried clicking on the menu to see if I could lock it onto Absolute, but whatever was making it flash prevented me from changing it or keeping it in place. I went to OSCulator and turned off pitch tracking for Wiimote 1 (again, the only thing I had on) and went back to Live. The drop down menu had stopped flashing and had settled on Absolute. I clicked it and selected Absolute from its choices just for good measure, then turned off MIDI Map Mode in Live and turned on pitch tracking for Wiimote 1 in OSCulator.

            And presto, no more sliding, just one-to-one pitch tracking as one would expect.

            I have no idea whether this solution will be lasting, but I think at the very least I've identified the problem. My solution for now will be extra caution when using MIDI Map Mode in Live: Prior to using it I'm going to go into OSCulator first to turn off all outputs except the one I intend to edit. Then I'll only have to contend with keeping one CC sane.

            Thanks again for all the help, Cam. I may have ultimately found the problem on my own, but I doubt I would have found the patience to keep at it without you helping me along.


            • #7
              Joel, this is an excellent one, thank you for letting us know !
              I will think of this later if someone else stumbles on this problem.