No announcement yet.

Incessant Joystick Button Firing

  • Filter
  • Time
  • Show
Clear All
new posts

  • Incessant Joystick Button Firing

    Hey all,

    Trying to use the Wiimote for computer gaming but I'm having an issue with the HID joystick. Whenever I set up anything as a HID anything I get random button firing from the virtual joystick. It seems that buttons 1-5 are all stuck 'on.' So when I go to configure the joystick in the game – in this case, Halo (mac) – when I go to set the commands it automatically sets them as button 1, 2, 3, 4 or 5 (which ever it registers first, I'm guessing).

    What is causing this, it's really frustrating?


    P.S. Cam, OSCulator is freakin' awesome. Blows Darwiin and Wiiji out of the water. Props man.

  • #2

    Thanks for the nice words, much appreciated!
    I am bit worried about what you say about the HID virtual joystick.
    I've had a report from another user having the same problem a few weeks ago, so I've double checked the code and tested with a few games but did not manage to reproduce the issue...

    What version of OSCulator are you using?
    Would you mind sharing your oscd file with me?
    If it's ok, please send it to camille at osculator dot net.

    Also, could you please try something: Assign buttons 1 to 5 to buttons on the Wiimote, and press / depress them to be sure they have the value 0. Then launch Halo and see if you have the same problem or if the behavior changed (to something better).

    Thanks for letting me know.



    • #3
      --Already tried button assignment, but gave it another go. Values all zero. Joystick axis's at 0.5 where they should be (?). Problem persisted.
      --Also, there are 2 HID joysticks showing up when I run Halo. One is called 'HID Virtual Joystick 1 (2)' and the other 'HID Virtual Joystick 2'. 'HID Virtual Joystick 1 (2)' is the one that actually responds .

      I'll send you the file here in a second. Thanks for the quick reply!
      Last edited by whatsiteverwas; 06-12-2011, 01:41 AM.


      • #4
        Alright, version uses an older version of the HID virtual Joystick which has a bug I believe.

        I would suggest you use the latest version of OSCulator (2.10.7 or the beta version on the Beta section of this forum).

        If you must really use the legacy version, I can update the kernel extension and release a maintenance update of Just et me know.

        Thank you for the file, I will have a look, but I'm pretty sure this is cause by the older version of OSCulator.
        Last edited by camille; 06-12-2011, 10:44 AM.


        • #5
          Updated. I still have the same issue in Halo... I tried it out with an old MS-DOS game via DOSBox and it worked fine... weird.
          Last edited by whatsiteverwas; 06-12-2011, 05:23 AM. Reason: Update


          • #6
            My previous answer was not very clear, I've updated it. Please update to a more recent version.



            • #7
              Maybe I wasn't very clear? I updated to 2.10.7 and I still had the same issue. I also tried 2.11 and had the same problem. I'm beginning to suspect the issue is with Halo...


              • #8
                Did it asked you to update the perfect pairing extension?
                This is the thing that needs to be updated.

                You can force the update by unchecking / re-checking the Perfect Pairing item in the Preferences. Restarting the computer helps ensure the extension is really updated.

                Sorry for the trouble.


                • #9
                  Messed with perfect pairing, I have the most recent version. Still its messed up. Did you catch that the joystick is showing up as 'HID Joystick 1 (2)' It seems as if there are 2 number 1 joysticks. Is this a part of the problem? Why would Halo be 'seeing' the joysticks this way?

                  I've searched google thoroughly and can't find anything about this happening with any other joystick except this.


                  • #10
                    Hey Jon,

                    The joystick names should be "OSCulator HID 1" and "OSCulator HID 2".
                    "HID Joystick 1 (2)" sounds weird.

                    It seems from the post you've sent there is another user having the same problem.
                    As far I can tell, I have triple checked the HID code, and it looks like there is no error.

                    Sorry !



                    • #11
                      Best I can figure its an issue wtih Halo itself... possibly an issue with a torrented copy.
                      I did manage to get the nunchuck joystick to work well though by splitting the X and Y axis and assigning them as keys.

                      Now the one thing preventing me from glorious Wiimote Halo is the mouse sensitivity. Works fantastic as a mouse on the desktop but again, as soon as Halo launches, everything goes screwy. In Halo the IR mouse is WAAAAAAAYYY more sensitive. I've messed with the IR sensitivity, IR smoothing and even the mouse sensitivity in Halo but none of it gives me the exact precision I need. Is there anything else I can do to get the calibration spot on, or should I give up this fantasy once again?


                      • #12
                        When using absolute mouse movement, the mouse can be a bit sensitive. The sensitivity has been chosen to give the best experience when using the mouse on the computer screen.

                        Here's a trick you can try to reduce the range of the mouse.:
                        Switch to scalings view, and locate the messages corresponding to X and Y. Set Output min of both X and Y to 0.2 and set Output max to 0.8. You can try with other ranges like 0.4 and 0.6 as long as they are centered on 0.5.