Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: OSC feedback ? Ipad + Mac + Traktor

  1. #1

    OSC feedback ? Ipad + Mac + Traktor

    OK, here's my pb:

    My setup, right, now, is controlling Traktor. Fine.

    But I wanna add duplex communication. I want my buttons to light on when they're on, and off when they're off. I want my buttons/faders/etc on my ipad to follow if I move them directly (with my mouse) on Traktor.

    For the buttons, I'm just adding a MIDI OUT in traktor on the same CC channels. OSCulator routes it back to the ipad, it works great.

    The pb is the faders. Mine are relative, most of the time, to avoid touching one by mistake... while trying to touch another one, of course.

    When I create the MIDI OUT from traktor (anc back to the ipad with OSCulator) it just makes my faders act epileptic ! It seems to me, when I move a fader on the ipad, that the information goes down to traktor, then come back to the ipad, then goes down again to the traktor... etc...

    I just need the information to go from the ipad to traktor and back !


    If they are ABSOLUTE, it's not a pb.... but absolute fader, in my situation, are just too dangerous !


    If someone got any idea, I'll take it. maybe it's a feature request ? I don't know... as I'm not sure the reason why.

  2. #2
    Hey krr,

    Absolute or relative is only affecting the way the control reacts to touch.
    Value positioning is the same wether the fader is absolute or relative.


    Cam

  3. #3
    damn.. I know my description isn't clear.

    here's a video that shows the pb:
    http://www.youtube.com/watch?v=kz9Au2ZU23U

  4. #4
    ok, I got it.
    your video shows very clearly that there are two problems involved :

    1. Traktor sends back values as it is updated. (for me it is an error if an endpoint, here Traktor, sends back a value when it is not the originator of the change.)
    2. TouchOSC continues value tracking as the finger is in contact with the screen.

    One solution you could use is to enable /z messages in TouchOSC, and use a Enable message in OSCulator to disable your fader's update from MIDI.
    The steps :
    • enable /z messages in TouchOSC (check out the settings screen)
    • touch your fader
    • assign to this fader the Event Type "Enable" and the Value "/midi/cc28/11"
    • touch again your fader, the message /midi/cc28/11 should be disabled
    • click on the enable checkbox (first column) to enable the /midi/cc28/11 message when the fader is not touched (and disable it when it is touched).

    All of this is a big hack, but you wouldn't need to do that in the first place if Traktor was not sending spurious values updates like this, or if TouchOSC was not paying attention to new values when the finger is pressed. If you have a look at Traktor, maybe you could find there is an appropriate option.


    Best,
    Cam

  5. #5
    OK, I can't try it now, as I'm @ work, I'll do ASAP.

    in fact, I need to be in relative mode: to change something in relative mode, one needs to "move" fingers while touching the screen. In absolute, a single touch is enough to change the value: I think it's dangerous especially when you got a lot of controls at once on the screen. Relative is safer...

    The ouput "back" from traktor is need to update the fader position when there's something else than the ipad that change any fader or pot value: automatic reset (I sometimes use it), or double click to reset a value to zero (I often use it).

    here's why I'm doing/needing this. Anyway, I'm gonna try your solution and will keep you informed.


    Anyway, great piece of software and nice support. I like that and will let it know to my students (:

  6. #6
    great. got at last enough free time to give a try again.. seems your "hack" is working... this means a lot work to make it properly work but it seems to work... at least with one fader (: I'm gonna build my setup and give a try with a mix on traktor.

  7. #7
    Quote Originally Posted by camille View Post
    ok, I got it.
    your video shows very clearly that there are two problems involved :

    1. Traktor sends back values as it is updated. (for me it is an error if an endpoint, here Traktor, sends back a value when it is not the originator of the change.)
    2. TouchOSC continues value tracking as the finger is in contact with the screen.

    One solution you could use is to enable /z messages in TouchOSC, and use a Enable message in OSCulator to disable your fader's update from MIDI.
    The steps :
    • enable /z messages in TouchOSC (check out the settings screen)
    • touch your fader
    • assign to this fader the Event Type "Enable" and the Value "/midi/cc28/11"
    • touch again your fader, the message /midi/cc28/11 should be disabled
    • click on the enable checkbox (first column) to enable the /midi/cc28/11 message when the fader is not touched (and disable it when it is touched).

    All of this is a big hack, but you wouldn't need to do that in the first place if Traktor was not sending spurious values updates like this, or if TouchOSC was not paying attention to new values when the finger is pressed. If you have a look at Traktor, maybe you could find there is an appropriate option.


    Best,
    Cam
    I came back two hours ago to my set up...; to finish it. For some reason, I can't use your trick anymore: I can't enable anything from /Z message to /midi/ .... Osculator only allows me to enable it to the OSC values which are already in my setup.... ? got an idea ??? I would like to use it on stage tomorrow nite....

    edit: damn.. it came back.... what did I do ??? argghh .. this is an unbearable feeling.. to solve something without understanding what you just did to solve it... -_____-'
    Last edited by krr; 04-23-2011 at 07:37 PM.

  8. #8
    Ok, As I'm working on my iPad/Traktor setup, I've tried it... and noticed that when I push the Cue or CueP button, the tracks doesn't start all the at once... I guess this is because there's latency on wifi.... plus time for osculator to translate things.

    is there a way to avoid it ? I've tried on my freebox wifi (the one I use all the time for internet access), I've tried my Airport Express (which is not connected to internet and with only the laptop and the ipad connected.. to avoid any kind of interference)... in both case, random lantecy.

    is it possible to have a direct access using USB ?? or is it too hard/long to program ?

    maybe it's possible using MyWi... but I need to jailbreak my ipad... (and dont really want that right now for several reasons....)

  9. #9
    If you can not configure an event with a /midi/xxx message, the only obvious reason I see is that you have not received any MIDI message yet, and therefore there is not message to use in the list.

  10. #10
    Sorry USB is not possible unless you use MyWi an jailbreak your iPad (see that post http://www.osculator.net/2010/07/19/...sb-connection/).

    The best way to connect an iPad to a Mac on stge is to use a small Wifi to Ethernet router that is plugged to the Mac. An Airport Express will do, but don't connect you Mac wirelessly.

    The freebox is one of the worst wireless router, don't use that.

    FYI OSCulator virtually takes no time to process the messages, the only latency you can observe is caused by the wireless network.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •