Results 1 to 5 of 5

Thread: Cannot get CC values for Wiimote in Ableton Live

  1. #1
    Member
    Join Date
    Apr 2011
    Location
    Atlanta, GA
    Posts
    3

    Cannot get CC values for Wiimote in Ableton Live

    I purchased Osculator yesterday along with a Wiimote. Since i have OSX.4, i downloaded the "Legacy" version. I read a tutorial online showing how to use the motion-based parameters of the Wiimote to send CC info to Ableton Live to control knobs, sweeps & things like that. However, my version of OSCulator does not have a cc value for the CC Event type, just 0-127 rather than cc1, cc2, etc.

    

I tried just to use one of those values with midi-mapping a return knob, but the knob just wobbled around in about the 40% range. It would go up if i raised the Wiimote, but never all the way down to 0. How can i get this kind of control with this version of OSCulator?

    

By the way, as a Latin teacher, i really appreciate the name of this software : ) You have obviously read your Catullus!

  2. #2
    Hello,

    The version you have downloaded must be a bit more recent than the tutorial you followed.
    In fact cc1, cc2, etc was the old name for MIDI CC event values (originally taken from the notation of MIDI CC message on Symbolic Sound's Kyma Workstation).

    The way your return is controlled is depending of what message value from the Wiimote you are using. I can't give you an exact answer because I don't know if you have used the pitch, roll or yaw value. To have an idea of how a parameter behaves, I would suggest you use the Quick Look tool (select the message value, and press the space bar, or click the Quick Look icon in the toolbar). Please let me know how you have set up the mapping, and I should be able to be more precise.

    About the name: Glad to know you find it inspiring! Actually the name was suggested by a friend of mine, and I liked it because of the word trick on OSC (Open Sound Control), the mathematical reference (an osculator line). Because it also means "the one who kisses", the application originally has an icon of the mouth from the Girl With Ball by Roy Lichtenstein. Don't ask me why, but French people find that the name has a sexual reference, and this previous icon didn't make the things better!

    Best,
    Cam

  3. #3
    Member
    Join Date
    Apr 2011
    Location
    Atlanta, GA
    Posts
    3
    Thank you for the quick response, Cam. I posted a Quick Reply, but it appears to have been lost somewhere in cyberspace : /. I'll reconstitute it here.

    I am using version 2.9.6.1 if that helps.

    I was using the pitch control Event type with the value set to 7. I sent the input to Ableton (set as a Track and Remote input). As soon as i did that, it sent a constant value to Ableton--the little yellow box in the corner was solid yellow. As soon as i turned on MIDI Map mode, it instantly mapped to any control i clicked on--Knob, button, launch, etc.

    When i tried to use it as a control on the Knob, the Knob went about halfway up as though the minimum value were something like 48, even though it was set to -Inf as a minimum in the Ableton mapping. It would go up if i raised the pitch and down to about 27 when it went all the way down, but never entirely off.

    So there are a few problems

    1) Sending a constant MIDI message to Ableton that overrides any other attempts to map another parameter

    2) Insufficient control over mapped parameter

    Hope this clarifies. Thanks so much!

  4. #4
    Hi,

    I understand that once you have mapped one parameter to Live, then it becomes difficult to map another one or simply stop this parameter from being re-mapped to another. This is a problem with Live, and it is normal due to the fact that the Wiimote continuously sends data. You need to disable the signal for a moment while you are learning parameters in Live (click the checkbox in front of the Wiimote parameter you want to disable, another way of doing this is to use the Routing Solo command).

    As for the second item, I am sorry but I don't understand what is the problem. I understand that the knob you are controlling is not reaching the full extent of the desired range, but this could come from many parameters. Have you tried the Quick Look window and see if the graph is accurate with regards to what you are expecting? This would be the first step to do.

    For you information, the Pitch has a value of 0 when the remote is fully turned down to the ground, and a value of 1 when it is fully turned up. If you want a narrower range, you can adjust the range by changing the values in the Scalings Page (cf View menu, then Scaling Page), then change the output min and max parameters (values between 0.0 and 1.0 in OSCulator 2.9).


    Best,
    Cam

  5. #5
    Member
    Join Date
    Apr 2011
    Location
    Atlanta, GA
    Posts
    3
    Dear Cam,

    Ok, i changed the value parameters and now it works perfectly! Thanks very much for the help.

    best,

    lance

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •