Results 1 to 4 of 4

Thread: OSCulator with Pro Tools 9

  1. #1

    OSCulator with Pro Tools 9

    Hi guys,

    I'm pretty new to OSCulator and am having a little trouble getting it running with PT9.

    I used OSCulator a few years back running with reaktor and logic and seem to remember it just worked and was very straight forward to assign different actions to certain parameters.

    Im trying to achieve something that in my mind should be quite easy in pro tools. I'm using TouchOSC with a few pads to trigger midi notes that are playing my midi instruments in PT.
    One set of pads is assigned to one instrument, the other to a different one. However, no matter how much tinkering I do with the routing I can only get both sets of pads coming through one instrument at a time. What I need is for one pad to play one instrument and the other to play the other one.

    I tried sending the buttons down different midi channels in osculator but still the same thing. The only way I can seem to change which instrument the pads play are by changing the midi through instrument to the one I desire in pro tools prefs.

    Someone, please help!

  2. #2
    Hello Peeksuk,

    Have you assigned different MIDI channels for each MIDI track in Pro-Tools? I think that by default MIDI tracks in Pro-Tools are "omni" meaning that they respond to all MIDI channels. If you set-up OSCulator to send message on different channels, and assign the same channels for your tracks, it should work as expected.


    Best Regards,
    Camille

  3. #3
    Hi camille,Thanks for the reply. I did try that yeh. So I have two midi tracks, each being fed by a different output from osculator, the midi track is then sent into the corresponding instrument but I still get the same thing :SI'm just a little confused as to why setting the midi through instrument seems to make all the difference. I would of thought if I set that to none it shouldnt matter as I don't want anything to send and receive midi data. Theoretically I believe all I need to do is what you suggested. Assign my osculator outputs to 2 different midi channels, set the two midi tracks in pro tools to those two channels and then have them feeding the different instrument but it just ain't working for me!Any other ideas or work arounds??

  4. #4
    I worked it out, pretty embarrassing really. You need to have record enabled to hear your input in pro tools 9 as there is no input monitoring. Oops! Thanks though.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •