Results 1 to 6 of 6

Thread: How to setup TouchOSC on a DroidX with a Macbook Pro? (DroidX + Osculator + MBP)

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    How to setup TouchOSC on a DroidX with a Macbook Pro? (DroidX + Osculator + MBP)

    Hey everyone. So I am attempting to get the android version of TouchOSC running with osculator from my Droid X. I tried to follow the advice of another poster using an android tablet and create a WEP network, but I guess there is a bug in the Droid X that it won't connect to these sorts of network and mine seems to have it (Gets to the "obtaining IP" message, after about 60 seconds it stops and connects to my regular home wifi connection.)

    I'm guessing I could connect it through my regular wifi, but I'd like to make it work with just the computer and the phone so I can do this on stage eventually. I have been able to get the phone connected to the computer through bluetooth, but was unable to figure out a way to get it connected to osculator. My roommate even connected his touchosc running iphone to my computer via bluetooth, then we copied the "host" field into my app on my Droid X with it connected via bluetooth, and it still did not receive messages.

    Is it possible to use the Android TouchOSC app via bluetooth to osculator? I haven't been able to find a way.

    Eventually I will use this to control Ableton but there is plenty of documentation on that step.

    Thanks!

  2. #2
    Hi what,

    When you create an ad-hoc network from your computer, there is no DHCP server.
    The DHCP server is a program that welcomes new network hosts and give them an address.
    This is why your Droid X is waiting for 60 seconds before bailing out, which is unfortunate because it should not need an IP address given from a DHCP server, it could just auto-allocate one and use that which is usually the case.

    Now, because your device really needs a DHCP server on the other side, here's a tip:
    You can create an ad-hoc network with your Mac that has a DHCP server in it. Just launch Network sharing form the System Preferences.

    Here are the steps:
    - Open System Preferences
    - Go to Sharing
    - Click on the Internet Sharing item (even though you may not need Internet, this is the functionality you need)
    - Configure the right pane as this: "Share your connection from Ethernet to computers using Airport".
    - Optionally, click on the Airport Option to customize the ad-hoc network name, etc. (here you want to use WEP I guess)
    - Finally, click on the checkbox next to Internet Sharing in the left pane to activate sharing.

    With this, you should be able to give you Droid X an IP address and hopefully use it with TouchOSC and Osculator.


    Best Regards,
    Cam

  3. #3
    Alright! I was able to successfully setup my phone using this advice. The other parts of it were as follows:

    In OSCulator I set the parameters under hostort to the IP given to my phone (which was listed next to "Local IP Address" under "Network" in the Android TouchOSC app.) and then :8000, so it was formatted as phone.ip.address:8000 in the parameters field.

    Then, for the host field in the TouchOSC app, I looked up the self assigned IP address of the laptop by going to Network - > Advanced while selecting Airport. In the advanced pane click on the TCP/IP tab at the top and you will find the computers self assigned IP, which you will then enter into the Host field in the Network pane in TouchOSC on your phone.


    The only problem with this setup I have found is my phone is not able so far to connect to the network I make when I set any kind of encryption on it (either 40 bit/5 char or 128bit/13 char). I suppose the odds of someone at your show having touchosc, connecting to your laptops network, and then being able to control osculator are probably pretty slim but I'd still prefer for that functionality to work. Just to be clear this is a problem with the DroidX and Android connecting to my laptop, and not TouchOSC or OSCulator.

    Thanks a ton, hope this info helps someone, I was unable to find anything about this specific instance anywhere online. If I figure out how to do it any other way I will report back.

    - what

  4. #4
    Good news: You can do this exactly the same way, except in the Network sharing pane, set it to "Bluetooth PAN" instead of "Airport". You will be able to send OSC messages to OSCulator from TouchOSC, and then you will also be able to use Airport separately to connect to your wifi.

  5. #5
    Excellent !
    Have you been able to setup a password for this network?

  6. #6
    So I went into the network sharing pane, setup from "ethernet" to "bluetooth pan", and then put 40 bit encryption on it and set a password. Once I connected the phone to the laptop via bluetooth and set the IP information in TouchOSC and OSCulator, it still works. I am a bit confused because it never asks for a password with it setup through bluetooth like this, even though I set it up to have one in Network Sharing. Perhaps this setting is ignored for a bluetooth connection? Either way, since it is sourcing the internet sharing from "Ethernet" and not "Airport", there is no internet connection on this bluetooth setup, if I understand this correctly, since I am using the airport for internet.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •