Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Love Your Product, But I need Help..Please! MIDI LOST

  1. #1

    Exclamation Love Your Product, But I need Help..Please! MIDI LOST

    I've been using Osculator w TouchOSC for about 6 months and overall it's been working great. I 'm using with Digital Performer 7.22. I basically use it for key command shortcuts, which has been a huge timesaver while working. I do have a volume fader along w an expression fader. All has been working great, until today! I've been trying to get a bit deeper into the program, bc I know how much it can do, but I really don't understand how to do it.

    Today, I added a few more basic key command buttons, and for some reason, my volume and expression fader are now not working. The way they worked before, was whenever a midi track was record enabled, those faders would work for that one channel. I have no idea how I got it to work that way, it just did. It's actually the only way I could get any faders working (I actually do like having it this way). I've read through the manual, but it's still just not clear to me on how to set it up through Digital Performer so it sees the midi. I know you've written in other posts you're not too familiar with DP, but any explanation regarding if I need to set up core midi, or whatever..would be helpful!

    I would love to have a bunch of faders and have them assigned to midi faders in my sequencers mixer. Every time within performer that I try and 'assign midi controller' to something, whenever I move a fader in TouchOSC, nothing registers within DP. In Osculator, that command lights up, but nothing though digital performer. All my keep commands work great though...just no midi. Any tips or tricks for this novice, would be very much appreciated!

    I've attached a few screenshots to see if I'm way off in my setup....

    Thanks!
    Marc

  2. #2
    Hello Marc,

    It seems from the TouchOSC Editor layout configuration you sent that you have configured your fader to send MIDI messages. This means that TouchOSC will use its own MIDI ports to send MIDI. For this, you need to configure TouchOSC on your iPad to use the MIDI feature.

    Since you are already using OSCulator, I would recommend that you simply set the faders to send OSC messages. They will be received by OSCulator (you can check that by looking at the activity monitor) and they will be translated to MIDI Control Changes as it is defined in the OSCulator configuration you showed.

    Simply put, you must choose one way of transmitting MIDI : either via OSCulator (using OSC messages from TouchOSC and then MIDI from OSCulator to DP), or via TouchOSC (directly using CoreMIDI to send messages to DP.

    I hope this helps!


    Best,
    Cam

  3. #3
    Problem solved! Thank you so much!

    If anyone has any digital performer templates, let me know! Mine is pretty basic and I'd love to figure out some cool things to do with Osculator.

    Thanks again.

  4. #4

    Not working again!

    Well, I added new faders this morning...and now none of them, plus my main volume fader (that was working yesterday) are working. It seems that anytime I update my touchOSC and Osculator, I lose the connection w my faders? This is getting a bit frustrating. I've restarted my computer, the programs, digital performer... still no luck. All my key commands I have setup within osculator are working, just not the faders. Any ideas?


    Could it have something to do that when I add my new layout to from TouchOSC it's now showing me 2 found hosts? They're the same name?


    Screen shot 2012-01-24 at 10.51.37 AM.jpgScreen shot 2012-01-24 at 10.51.33 AM.jpgScreen shot 2012-01-24 at 10.51.26 AM.jpg

  5. #5
    Hello Marc,

    Your layout shows that you have used a different type of control for the faders, here a Multi Fader.
    The messages they send are not the same as faders. Here's the documentation for this control on TouchOSC's website: http://hexler.net/docs/touchosc-cont...nce#multifader
    As a consequence, the MIDI CC in OSCulator are not triggered because they are assigned to other messages.

    Also, if the key commands are still working it means that the connection between your iPad and computer is fine.


    Best,
    Cam

  6. #6
    My single fader doesn't work either. Is there a simple way to explain how to set up 1 fader that will work within my program. The strange thing is, it worked yesterday when I first set it up, and I haven't done anything except added new faders to my touchosc template. I guess I shouldn't have tried to add anything new to my template when it was working fine...
    Thanks for your help!

  7. #7
    It should be easy if you follow these steps :
    - move your fader in TouchOSC
    - look in OSCulator what message has activity. This means that a yellow or green led should light up in the list. You can also sort the messages by activity by clicking the table header button just above the activity leds. Then move the fader again and it will be displayed at the top of the list.
    - now, knowing what message is received, look if it is assigned to the correct MIDI Control Change. If not fix it by assigning the correct MIDI CC. Otherwise, you should see what this MIDI CC means for Digital Performer, for example, is it something that it is supposed to receive ?

  8. #8
    So, when I move my single fader, it lights up green within Osculator.

    Settings:

    Message /1/fader2
    Event type MIDI CC
    Value 7
    Channel 1

    I then go to DP and in the mixer window I click 'attach midi controller'. When I then move the fader in touchosc after selecting which DP fader I want to control, it doesn't attach to DP (it is still green in Osculator). I can move a fader on my keyboard, and it attaches fine, just not using touchOSC.

    Something is not right somewhere..I just can't figure out where.

    Thanks for your patience...
    Marc

  9. #9
    It looks like the configuration is alright.
    Now, as you may know MIDI CC 7 has a special meaning, which is Channel Volume. In the case of Logic, it discards such message, which is very confusing ; the solution is to use another MIDI CC (for example CC 9, Undefined), or another channel (for example channel 2).

    However you said it worked before, so maybe the problem is somewhere else. Have you checked that "OSCulator Out" is configured as a MIDI Input for DP? In Logic, this is not needed because it listens by default to every MIDI ports available.

    Is there a MIDI monitor in DP? Maybe it could help to see if MIDI is actually received?
    I'm sorry I don't have a lot of ideas, the problem looks so simple though!

  10. #10
    We may be getting closer?? :-) I've pulled up the midi monitor, and when I slide the fade in touchOSC, under 'software devices, Osculator OUT lights up blue'. There is also another menu (I'm not sure if it's needed), called control suface setup, which you can see in the attachment. The problem must lie within DP....very strange, bc it worked in the past!

    hmmmm...
    Marc

    Screen shot 2012-01-24 at 4.53.17 PM.jpg

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •