Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: start pairing stays infinetely until stop manually

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    start pairing stays infinetely until stop manually

    Hi all, I found after updating to the latest Osculator "Version 2.12.3", that when I start pairing from the gui it will stay there until I will press stop, no matter it will pair this would stay in pairing process. I think there is no issue relating to functionalism as it pairs but not quits as soon it will pair, hhmm makes sense ?
    Is not a big issue but it will create some problems at live performance moments, btw is there any way to create at the moment a standalone file created from Osculator ? like routine mappings and ratios, I know it can be saved I am just wondering if there is a way to make things lighter.
    Thanks
    K.

  2. #2
    Hi Konstantinos!

    The pairing is meant to run only when you pair a new remote, which means that when you start the pairing process it will run as long as you continue to pair new remotes. Once the remotes are paired you no longer have to pair them again. Just press any button and they will connect to your computer.

    As a last note, if the pairing process has been manually stopped, it will not start again unless you start it manually.
    You will find more details about pairing and connecting a Wiimote on this thread : http://www.osculator.net/forum/threa...OSCulator-2-12
    and in the manual.


    Best,
    Cam

  3. #3
    Hi I might have been a bit non clear, I mean even the pairing goes succesfully the pairing process will not stop automatically as soon it will complete the pairing, it will go until I will stop it and then everything fine.
    K.

  4. #4
    I see. So the behavior you expected was that the pairing process would automatically stop every time a device has been successfully paired? What about pairing several devices?

  5. #5
    I am currently using one.

  6. #6
    Since this is a one time operation it probably makes sense to stop pairing once done successfully. I will think about that for a future release

  7. #7
    I am not quite sure I understand, that used to work really ok and I haven't any similar issues with previous version of OSCulator.
    The problem is that I have to stop manually the start pairing hitting the button as it will not stop by itself as soon it will pair with the WiiMote.
    K.

  8. #8
    Hi K.,

    The pairing process has changed between OSCulator 2.11 and 2.12. The reason of this change is not only this new process gives a better connection, but also provides compatibility for every model of Wiimote. Finally, it enables you to connect the Wiimote just by pressing a button, like you would do on the Wii console.

    As I said, pairing must be done only once for each Wiimote, the you can forget about it. Since this is a one time operation, it does not occurred to be a problem to stop the pairing process once it is done.

    Please let me know if that sounds clearer, and let me suggest again the following thread and the section about the Wiimote in the manual: http://www.osculator.net/forum/threa...OSCulator-2-12
    And don't hesitate to let me know if there is anything I might have misunderstood.

    Cam

  9. #9
    Quote Originally Posted by camille View Post
    Hi K.,

    The pairing process has changed between OSCulator 2.11 and 2.12. The reason of this change is not only this new process gives a better connection, but also provides compatibility for every model of Wiimote. Finally, it enables you to connect the Wiimote just by pressing a button, like you would do on the Wii console.

    As I said, pairing must be done only once for each Wiimote, the you can forget about it. Since this is a one time operation, it does not occurred to be a problem to stop the pairing process once it is done.

    Please let me know if that sounds clearer, and let me suggest again the following thread and the section about the Wiimote in the manual: http://www.osculator.net/forum/threa...OSCulator-2-12
    And don't hesitate to let me know if there is anything I might have misunderstood.

    Cam
    Ok, I just found weird this small proceedings of OSCUlator as it was ok on the last versions, also why during the pairing says press the red button inside the WIImote for sync, instead of just press 1+2 button as it was in the previous ones.
    Sorry, I just can't find sensual all these small changes on the version.
    K.

  10. #10
    Hey K.,

    Pairing via buttons 1&2 is no longer possible. This method was not reliable and not compatible with newer Wiimotes. Moreover, there is a technical issue where letting a discovery process in the background (so it is possible to connect the remote via button 1&2) pollutes the Bluetooth spectrum.

    Please consider the difference between pairing (done once) and connecting (done many time).

    As I previously said, I don't understand why this new pairing method is a problem since this is to be done once only. I think those changes are very beneficial in the end. These changes have been implemented about one year ago and the new pairing method is pretty stable now.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •