Results 1 to 3 of 3

Thread: LiveOSC, Lemur, Osculator and Clip Names

  1. #1

    LiveOSC, Lemur, Osculator and Clip Names

    Hey guys,

    I've been fiddling with this about a week now and I seem to be getting nowhere. I've looked over this forum and found a post from Cam explaining how to get clip names into TouchOSC from Osculator and LiveOSC but I can't seem to make it translate over to Lemur (I own both).

    I know the iPad lemur is hard coded to receive incoming OSC messages from port 8000 which I've setup on the Lemur and Osculator. My problem lies within getting the track name to show up on a custom button. I've demux'd the /live/name/clip and can get the track names to show in Osculator, I have a OSC routing command to send it to a custom address of /trk/name/1 using arg 0.

    I've read on the Usine forums that users with Lemur can get messages to display by setting a script to take the incoming arg and display it in the text part of the custom button using this: setattribute(NameOfObject,'FieldToDisplayArgIn',OS C_ARGS); - in this case OSC_ARGS would equal 0. When I try this I get nothing. An example would be: setattribute(CustomButton1,'Content',0);

    I'm not sure what I'm doing wrong here. Does anybody have experiencing using all three of these together? Any help would be greatly appreciated!

  2. #2
    Hi John,

    Just asking naively, do you really need to call a script to set a label string?
    This seems overkill!

    I'd be happy to help you find a solution, to do so I would need you to provide me with a simplified example oscd file and Lemur layout.
    You can attach files to this thread (maybe a zip is best).


    Best,
    Cam

  3. #3
    Hey Cam,

    When I get home from work I'll send it over.

    Thanks for your help!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •