Results 1 to 6 of 6

Thread: turning proximity data off

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    turning proximity data off

    Hi.
    I'm using my wacom pen tablet with max/msp but don't wish to use any of the incoming proximity data as it sometimes sends unwanted x-y messages when i lift the stylus. There may be a really obvious answer to this, but I can't seem to disconnect it? i have tried simply un-ticking the proximity box, and switching off the event type and value information in the osculator window, but the messages are still being picked up in max.
    Any help with this would be much appreciated.

    Thanks

  2. #2
    Hi,

    I assume you are using the provided oscd file for the Wacom table and Max.
    Yes, unticking the "enabled" checkbox for each message whose name ends with "/proximity" will disable sending the message to Max. Make sure you have unchecked this message for every tool and pen in use. Alternatively, you can also modify the Max patch to filter out those messages.


    Best,
    Cam

  3. #3
    I'm not sure exactly what the oscd file is actually? i just set up an empty osculator environment and the messages that osc automatically picked up from the tablet are being routed to max. If i can, i'd like to disable the messages going in on the osculator end as there is some decoding going on in max that i don't actually understand - i'm using a downloaded preset patch.

    There is actually only one message ending in "/proximity" being picked up in osc, which is only lighting up when the pen is in range of sensor. I must be doing something wrong as i've just realized that max is picking up messages even when ALL the message enable boxes are un-ticked?

  4. #4
    oscd is the file extension of files saved with OSCulator.

    I think you must be using the Wacom example file found in the Samples Library, where you also found the Max example.
    It is not possible that you uncheck a message line and that the event gets triggered anyway.

  5. #5
    Oh right. Yes sorry i was mistaken about the messages still being sent with the boxes un-ticked. I'm just using a "New" file, and haven't selected any example files as far as i know. The max patcher is part of a bundle from cnmat - http://cnmat.berkeley.edu/patch/2802. There was also a wacom osculator file included in this but i haven't been using it.


    This is how the current osc file looks -
    Picture 1.png



































    In this state i am receiving all the information from the pen (x-y, proximity etc.) in max. It is only when i un-tick the "/wacom/1/pen/0" box that no messages are sent to max.

  6. #6
    Ok, thanks to your screenshot I better understand how this is working.

    I can see a couple of issues:

    1. There is no way for the proximity message to be sent to Max when the enabled checkbox is unticked. So what you should see in Max is solely the pen coordinates message. As you noticed, when nothing is checked, Max receives nothing. You should check in Max what happens when the pen coordinates message is sent.

    2. One advice: You don't need (actually, should not) assign an OSC Routing for a message, and also assign OSC Routing events for all the arguments of the message. You only need one, for the message. If you don't know what is the difference between a message and its arguments, I invite you to consult the first chapter of the manual, there is a short explanation about how OSC message are structured. Understanding this will help you process the Wacom OSC data in Max.

    Best,
    Cam

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •