Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Feedback from Ableton Drum Rack to Lemur thru Osculator

  1. #11
    Man, I have spent the past three hours trying to figure this out. I looked at your examples and tried to tweak my project to match it. I have everything figured out I believe except I cannot get the OSC Routing back from Ableton to work. What I mean is, I triggered the pad on Lemur, located the OSC message coming into to Osculator, assigned that to the MIDI CC for the appropriate drum rack cell. I set up the extra channel in Ableton. I received and located the Midi note returning from Ableton to OSC. I then did the Demux to locate the individual pitch of the pad I am triggering. From there, I try to assign the "trigger" line of that pitch to an OSC routing, which is the default and in which the iPad's (lemur) IP address has been written.
    I remember when I had a successful routing in an earlier project the "value" line of the target filled with a bunch of data/symbols. When I do it now, it just remains a lonely default symbol.
    Not sure exactly what's up but I believe the only issue I am having is successful communication from OSCulator back to the Lemur. I don't understand as I have quadruple checked the Lemur/iPad's IP address and seem to be receiving data from the iPad alright.
    What could I be missing?

  2. #12
    Hi PK,

    The problem does not come from the target IP.
    In what you are trying to achieve, you don't need to create or assign any OSC Routing.

    My example uses notes to trigger a drum sample, not MIDI CCs.
    With a note you don't need to do any mapping on the Ableton Live side, whereas with CC you will have to "map" them with Live's user interface.

    Also, the process of backmapping (which is routing back the messages from the target device, Live, to the controller, Lemur) is something that is automatic. You don't need to do all this configuration, the only required step is just to demux the /midi/note/1 message. Once this is done, and if you use MIDI Notes to trigger the pad, then backmappings are created automatically.

    Maybe you should try the example by just changing the default target IP address to your Lemur's, and see how it works. Then delete the /midi/note/1 message, play drums, and demur it. Then play drums again and see what happens.

    Best,
    Cam
    Last edited by camille; 06-09-2013 at 11:39 AM.

  3. #13
    Here is exactly what I have done:
    I downloaded all four files you gave me. I opened up the Ableton Live file, and the Drum Rack -> 808 Drum Rack (Lemur) file in OSCulator too. I don't have/can't find a template for Lemur called Drum Rack or anything so I used the Drum Pad in the "iPad Studio Combo". I then start playing the Pads and everything seems to work great. I record a line in Ableton and it feeds back to the Lemur, seems good.
    With the goal of understanding I try what you suggested and delete the midi/note/1 line (which has in the value field the "default" sign and a whole bunch of text reffering to the drumpad and such and when triggered, displays green).
    I then play the lemur again to get the midi not again which works fine. I then unscroll to reveal the Pitch, velocity and trigger lines. I select Pitch, then demux (Edit->demux) it. From there I start playing the pads again and it populates below with all the notes. However, there is no data (osc routing, default etc.....) in the trigger line below each note and the "enable" box is only yellow and not green like it was earlier. It seems this is where you say it should auto map back. Nothing ever seems to happen for me so I manually select "OSC routing" and then point that to the Default target, which only displays the default symbol, nothing else like before.
    I can't figure out what I am doing wrong. Should I be using a different template? If so, could you send me that one?

  4. #14
    You have to use the build I have sent you previously, using the "official" release will not work as expected ;-)

  5. #15
    Something I just realized..

    I tried repeating the whole process from scratch again. After everything was ready I tried recording a drum line in Ableton again. Here is where I realized that only some of the pads were working. When I checked OSCulator, I saw that the original "drum rack-> 808 Drum Rack (Lemur).oscd file you sent did not have those particular pads already setup. Now that they have joined in, their "trigger" lines are empty (no OSC routing nor "defaul - /Drumpads/x .....etc). When I manually assign them to OSC routing value= default symbol, nothing happens.
    It seems that the "auto-mapping" that occurs for your system will in fact work on my setup (I am referring to this OSC routing in the value field, "default symbol" -> /Drumpads/x : f:bref /Drumpads/x [0], f:bref /Drum......) but when I delete the /midi/note/1 and then re-obtain it, then demux it, I do not get any auto mapping. If I try to map it manually, I only get the "default symbol" in the target and nothing happens.

  6. #16
    Quote Originally Posted by camille View Post
    You have to use the build I have sent you previously, using the "official" release will not work as expected ;-)
    When you say build, are you referring to a Lemur Template? I don't seem to have one in the email you sent me.
    This is what I have

    osculator-2.12.8-4-g6b517d3.dmg
    Beatmachine -> 808 Drum Rack.oscd
    Beatmachine -> 808 Drum Rack Project.zip
    Drum Rack -> 808 Drum Rack (Lemur).oscd

    I ignored the Touch OSC template as I don't use that. Just Lemur these days.

  7. #17
    The dmg file contains a version of OSCulator that has been fixed to create backmappings for MIDI Notes.

  8. #18
    I am not sure if it could help, but remember that double clicking a file will not guarantee you that you are launching the correct application. If you want to try the OSCulator version I sent to you, make sure you deleted other versions, or launch it then choose File->Open...

  9. #19
    hehe...thx man, I didn't realize you were talking about an OSCulator build. I installed it and everything is working great. Thanks so much for continuing to help. I have learned a lot!

  10. #20
    Thanks, I'm glad to hear it's working!

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •