Results 1 to 7 of 7

Thread: Z messages not working anymore.

  1. #1

    TouchOSC feed back in Live

    I don't get feedback to TouchOSC anymore from live.

    Previously my faders reseted to zero in TouchOSC when i lifted my finger, but now they don't. It means that live does not regonize the Z message that OSCulator sends and does not send anything back. Or something.

    The little "midi out indicator" lights in Ableton do flash when i lift my finger.

    OSCulator does not show any incoming signals in the quick look window nor the green lights flash.

    How to debug this?

    And it's not only visual problem as the faders stay up in live too and that is bad thing. Don't want to have distortion on in master by accident :/

    Year ago this worked just fine and only thing i have updated is TouchOSC to v1.9.1
    Here's my OSCulator file:

    Last edited by Freeks; 06-21-2014 at 10:19 AM.

  2. #2
    Hi Freeks,

    The first thing to check is that TouchOSC sends something to OSCulator.
    It seems this is the case, but I am not entirely sure reading your description.

    Now, you say the problem is the feedback from OSCulator to TouchOSC.
    In order to work, OSCulator scans the local network and searches for a device it can send feedback messages to. It is called the "default target".

    Open the Parameters and go to the OSC tab. Because I don't have any TouchOSC running on my network, the default target is shown red as in this picture:
    Default Target.png

    When you launch TouchOSC, the red text should turn black, indicating that the device is there on the network, and so OSCulator can send messages back to it.

    I suspect there is a problem with the way TouchOSC is found on the network, and my recommendation is that you restart your iPad and computer. You said that your computer was running 10.5.8 and it is a well known problem that Bonjour discovery does not work well all the time, the computer must be restarted.


  3. #3
    Thanks for the reply Cam,

    I updated my live computer to 10.9 and installed Live 9.1 and latest version of OSCulator. In that setup i didn't get any messages to live via OSCulator. All the checkboxes in OSCulator were greyed out, but the green lights blinked when i did something in TouchOSC.

    So i went back to 10.5.8 via backup to get it back to working and now it sends the control messages, but no feedback.

    TouchOSC finds OSCulator host on port 8000 and that default target in Parameters is in black.
    I rebooted both, but still no feedback to TouchOSC or to live. I don't mind if the touchosc faders don't reset as long as the parameters in Live reset. In live i have setup midi ports in preferences so that OSCulator in and out both have track and remote on.

    There is another bug now that wasn't there earlier. I have buttons that trigger drum rack sounds in live. All buttons work as should, but the XY pad does not. It should send C1 from OSCulator, but that never comes to live. Again all indicator lights flash in Live, but the note is not triggered. So it seems that all parameters that have Z value does not work as XY uses Z value to trigger the note.

    So if the network connection is ok, how to proceed from this?


  4. #4
    Obvious question, but have you checked that the "Send Z messages" options is checked.
    It is possible that by upgrading the settings has been lost.
    I don't see from your description anything wrong with OSCulator.

  5. #5
    Stupid question, but where i can check "Send Z messages" option?

    I did check on the "Flash activity lights" and now i get green flashes for all other action than Z's.

  6. #6
    Sorry that i wasted your time.
    I RTFM and checked on the Z Messages in TouchOSC and everything works now.

    Thanks a lot!

  7. #7
    No waste of time
    I'm glad it works now.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts