Results 1 to 8 of 8

Thread: 3DConnexion Space Mouse Wireless

  1. #1

    3DConnexion Space Mouse Wireless


    is the Space Mouse Wireless compatible with OSCulator? If so, how do I get it working? The "use Space Navigator" option is greyed out from Window menu. The mouse is communicating fine with my Mac (Hackintosh). I want to be able to use the mouse to control parameters in Ableton Live via MIDI.

    Any advice greatly appreciated. My search for information will continue in the meantime.


  2. #2
    upon further investigation I came across a problem that is consistent on both my Macs. On my Hackintosh, while I had the usb dongle for the space mouse wireless plugged in, I didn't have the 3DConnexion drivers installed, so the 3d mouse was acting as a normal mouse when panned or tilted. However, now that I've got the software installed, Osculator quits on start, giving this error:
    Process: OSCulator [560]
    Path: /Applications/OSCulator ƒ/
    Identifier: net.osculator.OSCulator
    Version: 2.13.2 (20140918)
    Code Type: X86-64 (Native)
    Parent Process: ??? [1]
    Responsible: OSCulator [560]
    User ID: 501

    Date/Time: 2015-08-08 18:20:35.444 +0100
    OS Version: Mac OS X 10.10.4 (14E46)
    Report Version: 11
    Anonymous UUID: D901DC99-50EE-7289-3E5C-CF4D93ADAB6E

    Time Awake Since Boot: 1200 seconds

    Crashed Thread: 0 Dispatch queue:

    Exception Codes: 0x0000000000000001, 0x0000000000000000

    Application Specific Information:
    objc[560]: '/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient' was not compiled with -fobjc-gc or -fobjc-gc-only, but the application requires GC
    objc[560]: *** GC capability of application and some libraries did not match

    - When I tried to use osculator on my Macbook Pro running the latest and same version of Yosemite as my Hackintosh (10.10.4), I get the same error.

  3. #3

    Please see this thread:

    Have a warm and creative summer!


  4. #4
    Hi Cam, thanks for reply. unfortunately, using the app in 32 bit mode doesn't solve the problem...still getting the same error. Is there a conflict between the 3DConnexion software and Osculator? It seems the problem began with the installation of 3DxWare...

  5. #5
    Hi Ed,

    I'm so sorry I did not sent you the right link.
    Here is the proper discussion:


  6. #6
    HI Cam,

    unfortunately I do not see 3DxMacWare 1.7.2 on the legacy drivers page...

  7. #7
    great. It's working now. SpaceMouse Wireless is going to send MIDI to Ableton which will in turn send MIDI to a Teensy powering motors in a pan / tilt / slide camera motion rig

    Thanks for the help!

  8. #8
    MIDI mode on the Teensy is the most awesome thing on the planet!
    Sounds like a great project


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts