Hi Everyone, so a couple months back I set up an iPad with Lemur connecting to Osculator for a friend of mine. Everything was working fine until he just got a new router. Now Osculator is incredibly slow. I press a button on the iPad and it takes upwards of 15 seconds for Osculator to receive it. I'm wondering if there is a setting inside the router/firewire that would slow this down? Any help would be much appreciated. Thanks!

Using a Mac Pro (black) over wi-fi and a Sonic 5268 router.