Results 1 to 6 of 6

Thread: Balance Board MIDI not sending

  1. #1

    Balance Board MIDI not sending

    Hello,
    I've been using OSCulator for a number of years now, and am trying to use the Wii Balance Board as a MIDI controller.
    It connects no problem, and I get data from all sides, however, when I attach a MIDI note or CC, nothing seems to send to my outside applications.
    I set up some OSC routing to Quartz Composer, and it worked just fine- but no MIDI to Quartz or Ableton.
    I've checked all my routings, and even set up a WiiMote in the same OSCulator document as the balance board and it sent MIDI note and CC data to both Quartz and Ableton, via the same port, without a problem.
    Any ideas on what might cause this?
    Thanks,
    Peter James Crowell.

  2. #2
    Hello Peter,

    If I understand correctly, when using OSC Routings, the data is properly sent, but not when using MIDI CC.

    Have you tried to look at the Quick Look window with a CC or Note attached?
    To display a Quick Look window, select a message from the main list, and press the space key.

    Also, with a MIDI CC configured, when you act on the Balance Board, what color are the activity lights? They should be green or yellow, but never red.

    Finally, please tell us your Mac OS X and OSCulator versions.
    Thanks!

    Best,
    Cam

  3. #3
    You got it properly. Quick look is showing both MIDI note and CC sending. As I said, I'm sorta baffled since a WiiMote running in the same OSCulator document, on the same MIDI channels, is going through to LIVE and Quartz just fine.
    Activity lights are yellow. The OSC routings went green, because, well they worked.
    I'm running El Capitan 10.11.5 (15F34), and OSCulator 2.13.3 (20151010)

    A side note, this is a phenomenal piece of software which has helped my artistic abilities immensely, and am very grateful for it and your dedication to it.

    Thank you,
    Peter James Crowell

    EDIT : Button A sends MIDI. Just found that out. Green lit.

  4. #4
    I was able to get it to recognize midi notes by changing the in.min/in.max to .99 / 1.0. No velocity but whatever. I don't really need that.
    Still struggle to get the MIDI CC toggle down. Thanks for the help again!

  5. #5
    You are in the right direction.

    As you noticed, you need to adjust the Output Max so that the events are properly triggered. I should have thought about this before.

    The Balance Board is calibrated to report values in hundredth of kilograms. So a values of 0 means 0 kg, and a value of 1.0 means 100 kg. On another hand, you have MIDI notes that are triggered when the value crosses 0.5. For MIDI CC, this depends on the MIDI software you control, but for most of them, the trigger happens at the middle cutoff, that is MIDI value 64, or 0.5 if you consider the output of the Balance Board.

    Now, if you set the Output Max to something lower, for example 0.5. This will have the effect of lowering the threshold point of 0.5 to 0.25. In terms of the Balance Board output, you will need only 0.25 x 100 - 25 kg of force to enable the trigger.

    Feel free to experiment with the Quick Look window open, and choose triggering values that work with the software you want to control.

    Let me know if that works and/or if you need more details!

  6. #6
    This is working just great! Thank you!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •