Hi clik,

Can't see a Lock option where it used to be, under the Routing dropdown...
The UI changed a bit, OSCulator now leverages the Finder being able to lock documents.
Note there was a bug in the first beta where input locking would not properly work, this is fixed now, so please run the automatic update.

About the UI: right now in version 3.0-beta, open a Finder window, choose File -> Get Info, and check the "Locked" checkbox. Not only, it does the right thing by preventing accidental overwrite of the file, but also OSCulator locks the inputs.

In a future version of OSCulator, you will be able to lock the document right from the main window. This will be a bit more intuitive I guess.

Scroll bar behaviour - can you tweak the Scalings page to shift the Out. max column to the left away from the scroll bar? I know this is only an issue because I have the 'Show Scroll Bars' set to 'Automatically based on mouse or trackpad' in Sierra's System Preferences/General... or maybe an OSCulator preference to override that systemwide behaviour?
Good catch, this has always been quite annoying. I added dummy columns at the end of both the main list, and the scalings list so the hovering scroll bar does not get in the way. This change will be available on the next beta release, I'll post here when it's available.


Best,
Cam