Results 1 to 3 of 3

Thread: Ignore note off from keyboards?

  1. #1

    Ignore note off from keyboards?

    Hi everyone,

    I'm trying to create a scratch game with the input via a midi keyboard. Scratch accepts only letters and numbers. It is easy with osculator to route notes to numbers / letters with the keycode event.
    What's driving me crazy is the note off message on the midi keyboard. I am unable to find a way in which Osculator does not send out the message off note.
    I do not know how to choose just the notes on message (i want velocity and pitch) and ignore all the notes off (pitch, velocity, trigger).

    I'm sure I'm missing out on an easy way to do this.
    Any help Camile? ; p

  2. #2
    Serious User
    Join Date
    Jul 2010
    Posts
    38
    Try this - select your incoming midi message, then choose Demux from the Edit menu (or key command control D) - hit the same note on your midi keyboard again, the message is split in two - 0 and 1 - ignore the '0' (the Note Off part) - select and define the '1' message as needed.

  3. #3
    Thanks clik. Your comment has helped me, but I still can not solve my problem. I can explain myself better.
    I want to program certain keys (F # pentatonic scale for example) to move a doll through scratch. In Osculator I can get it doing Demux of the signal / midi / note / 1> 0: pitch. And assigning the output to keycode (A).
    I also want the doll to jump when the velocity value exceeds 2/3 of its range. I can do this with split velocity, and scaling the input (velocity (lo): 0.66-0 and velocity (hi): 0.66-1). The outputs would be a keycode A (lo) and B (hi).
    So far so good. The problem:
    Any midi keyboard sends note on and note off, but also velocity X (in a 1-127 range) and velocity 0. Osculator interprets all the messages it receives, sending an A when the key is pressed and another A when the key is released. I only need the first A and I do not know how to ignore the second A (velocity 0).
    I tried with different scaling, with the metaevent "enable" to deactivate the second message, and fumbled with the "Midi Message" control. Nothing has worked for me.
    The ideal would be a Demux of the Velocity parameter to isolate the value 0 and somehow stop the demux of the other values, since they are almost infinite. But once you do Demux you can not stop it anymore in Osculator.

    Another problem derived is that velocity is a continuous type value. And when I play a note within velocity hi, the notes off process them activate velocity (hi) and velocity (lo).

    I hope you can help me. Thanks in advance.
    Last edited by iogurt; 07-30-2017 at 10:25 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •