Results 1 to 10 of 10

Thread: system startup error

  1. #1


    hi everyone, im getting the following error message (in german language) on every system startup. what to do?


    http://www.jasonf.de/osc-error.jpg


  2. #2


    Hello Jason,


    This is a known problem that rarely but sometimes happens.

    Can you tell me what system version you are running?


    The solution to that problem is simple :


    - locate the file OSCulatorIOKit.kext in the /System/Library/Extensions folder

    - delete that file. BE SURE YOU ONLY PUT THAT FILE IN THE TRASH.

    - restart your computer (to be safe)

    - when the computer has restarted, launch osculator, and go in the Preferences, Inputs tab and re-install perfect pairing extension (if you use the Wiimote)


    Please tell me if that solved your problem, and don\'t forget to let me know your system version.


    Best,

    Cam


  3. #3


    hello camille,

    thanks for the quick reply.

    on my first try i realized that the OSCulatorIOKit.kext, wasnt on my system allready.

    so i deleted osculator, installed it again, trashed the OSCulatorIOKit.kext, restarted osx ,but the same error message showed up again.


    im using a macbook alu 13" with the latest osx 10.5.6


    great tool btw. i just switched from pc to mac, and therefore from GLOVEPIE to osculator and i am very happy with the easy interface and the good performance.


    greets iason


  4. #4


    Hey Iason,


    If the kernel extension doesn't seem to be installed, I believe that you have a problem with the kernel extensions cache.

    This is a way to speed the system startup, and there is no problem resetting the cache if you use the correct tool. I suggest you try the utility called Onyx (you can find it here).


    I hope this will fix your problem.


    Thanks for your kind message!


    Best,

    Cam


  5. #5


    I have the exact same problem. I'm really in need of a more permanent solution.


    My workaround:

    - Delete the extension.

    - Re-enable the extension in Osculator prefs


    However, once I reboot the system, The error is back. Next tuesday, I need to distribute 13 macmini's and less technical users have to be able operate it. I tested it on 2 machines with the following specs:


    Hardware:

    Model Name: Mac mini

    Model Identifier: Macmini1,1

    Processor Name: Intel Core Solo

    Processor Speed: 1.5 GHz

    Boot ROM Version: MM11.0055.B08

    SMC Version (system): 1.3f4


    Software:

    System Version: Mac OS X 10.5.8 (9L31a)

    Kernel Version: Darwin 9.8.0


    On a third MacMini with the following specs everything runs fine.


    Hardware:

    Model Name: Macmini

    Model Identifier: Macmini2,1

    Processor Name: Intel Core 2 Duo

    Boot ROM Version: MM21.009A.B00

    SMC Version (system): 1.19f2


    Software specs are identical, Bluetooth hardware/software specs are identical too.


  6. #6


    The Workaround I use doesn't always work. In fact most of the times it doesn't :-(


    I'm currently looking for a version of Osculator from around may 2009 (last year the whole setup did work)


    Let's say... OSCulator 2.8.8


    Anyone?


  7. #7


    Hi,


    I have not been notified of this problem since a long time.

    Unfortunately for you, an older version will not help since it is basically the same component.


    A couple of questions:

    1. Can you tell if the computers that are exhibiting this error message have been upgraded from Mac OS X Tiger?

    2. Have you tried to reset the kernel extension caches like described earlier in this post? (uninstall Perfect Pairing extension first).


    You could also run the Disk Utility and run the repair the permissions process after resetting the kext cache.


    I can have a more detailed look at your system configuration if you send me an Apple System Profiler report. Click on the Apple menu, then "About This Mac", and click on "More Info …". The Apple System Profiler application will open. Save the file to the disk, and send it to me, camille at osculator dot net.


    Best,

    Cam


  8. #8


    Just checked with an support discussion I had by email on november 2008, and the user reported that cleaning the system extension cache and repairing the permissions resolved this issue. Please try that, and tell me if that works for you.


  9. #9


    OK. This did make the error disappear at boot-time.


    1. I downloaded Onyx and cleaned cashes
    2. used Disk Utility to repair disk-permissions
    3. deleted /System/Library/Extensions/OSCulatorIOKit.kext/
    4. deleted ~/Library/Preferences/net.osculator.*
    5. deleted all devices in the Bluetooth preference-pane
    6. started Osculator, installed PerfectPairing extension



    So now I'm back to where I was about 6 hours ago: Devices don't connect properly

    1. They appear in the drawer
    2. WiiMote buttons do work
    3. All 4 lights on the WiiMote keep on flashing
    4. WiiMote battery-status sometimes displays in the drawer
    5. My infrared LED's are being ignored



    Different thread?


  10. #10


    I was not aware that your remotes were not connecting properly.

    My support here was targeted at helping you get rid of the error message.


    I need some more information about the Wiimotes, or I will not be able to understand the problem.

    Please send the Bluetooth addresses of your Wiimotes by email. You can find them in the Wiimote drawer, this is the list of numbers and letters like 00-xx-xx-xx-xx-xx.


    We will decide what to do next.


Similar Threads

  1. auto connect Wiimotes on startup?
    By gpvillamil in forum Wiimote
    Replies: 1
    Last Post: 09-29-2010, 07:33 AM
  2. system/instrument volume via tilt
    By Hatchinatore in forum Wiimote
    Replies: 5
    Last Post: 07-24-2009, 09:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •