Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: TouchOSC + Osculator w/ Created Network on Mac

  1. #1

    Hey all,

    I've been using TouchOSC w/ Osculator and Traktor on a mac for something like 6-8 months now but have recently run into some problems. I'm hoping somebody else can either confirm the same issue or has an idea of what's going wrong.

    I create my own network (so I don't have to rely on a public wifi spot when DJing) by going to the Airport icon and clicking "create network". Then I join that network on my iPhone, fire up TouchOSC and then if I go into the network config section on the phone I see the available Osculator ports on the network and can select the one that I want. It has always worked flawlessly.

    However recently it started not working. If I go into the network config section and select one of the available found Osculator ports it removes the host name, changes the outgoing port to -1 and the incoming port to 100001 and the local IP to I have NO idea why this is happening and the only way I've been able to get TouchOSC communicating with Osculator is by joing a mutual network.... then things work smoothly.

    Has anybody experienced this? I'm not sure if maybe a recent OSX software update changed the way the computer broadcasts its settings.... or what. Thanks!


  2. #2

    Hi Todd,

    AFAIK, nothing has been changed in the network code of OSCulator since a few releases.

    The only thing I could think of is the recent update of TouchOSC to version 1.3.

    Maybe your problem is related to that? I can't test it right now, and I have not used TouchOSC since I've upgraded the app on my iPhone.



  3. #3

    Hey Todd,

    FYI there's a new update to TouchOSC.

    Version 1.3.1.


  4. #4

    I've had several users writing me that they had problems with OSCulator, TouchOSC and a created Airport (aka ad-hoc) networks. I am not exactly sure what is the cause of the problem, but I sense that the new iPod/iPhone OS (v3.0) has a problem with ad-hoc networks.

    You can tell you have the problem if TouchOSC or OSCulator has a difficulties to detect each other, or, even though you have the Airport icon in the status bar of the iPhone, no data is sent to OSCulator (green lights not flashing).

    As a workaround I suggest to manually configure the IP addresses of each device, in the wait of the next OS revision:

    - On you Mac, create a network as usual.
    - Open the application Network Utility, and in the first screen, select the Network interface that corresponds to your Airport interface (it is usually en1). Write down this address, for this particular computer, it will never change (unless you connect to a router).
    - On your iPhone, go in TouchOSC, open the Network settings application. The IP address of the phone is written in the "Local IP address" field. For a ad-hoc network with your computer, this should never change as well (unless the connection method is different).

    Now that you know each of the devices IP addresses, you can use them to manually configure each application.

    - in TouchOSC, go in the Network settings. In the "Host" field, write the IP address of your computer. In the "Port (outgoing)" write the OSC port that OSCulator listens to (default is 8000). Incoming port can be set to 9000.
    - in OSCulator, open the document you are using, and open the Parameters window, then go in the OSC Hosts tab.
    - Click the '+' sign to add a route, and replace localhost with the IP address of your iPhone.
    - Select this route in the Default Host pop-up menu.

    TouchOSC and OSCulator should be able to communicate together again.

    Last edited by camille; 06-22-2011 at 02:49 PM. Reason: formatting

  5. #5

    Hi Cam,

    please, i need your help.

    i´m using the newest software versions of

    MAC OS X (10.5.8)

    Ableton Live (8.0.4)

    OSCculator (2.8.7)

    Iphone 1.Gen (3.0.1)

    TouchOSC (1.3.1)

    SonicLife (1.2.2)

    with a connection from device to device or with a router it´s display in the

    network monitor incomming signal on my mac but not in OSCulator or Live

    no flashing lights with the presets and no incoming data on a clean default.

    i try the tutorial and your post to create a direct network search the forum

    and see video´s on youtube. on this video it looks so easy

    TouchOSC + OSCulator + Live

    what´s wrong? do you have any idea for my problem?



  6. #6

    Hi Jack,

    I have a few questions to ask so I can understand your problem:

    - When you touch a fader or a button in TouchOSC, does it create a line in OSCulator's window?

    - Have you tried the pre-configured examples? Does it work?



  7. #7

    Hi Cam,

    - no lines created by touch a fader or a button

    - yes i try the pre-configured. it doesn't work



  8. #8

    Hi Jack,

    Thanks for the details.

    So, that means that TouchOSC is not sending anything to OSCulator.

    Could you make sure that TouchOSC network configuration is ok?

    When you go in the TouchOSC configuration page, you must see that there is a running OSCulator instance on your network. When you select it, it will fill the network configuration with the information about the running oscltr.

    BTW, there is something very annoying with the OS 3.0 for the iPhone, it doesn't seem to "stick" with the selected Airport network. Please make sure that the Airport icon is shown when you launch TouchOSC as well …



  9. #9

    This is really strange. It works fine with wifi, but not computer-to-computer network.

    I have iPod Touch 2gen. Running Leo 10.5.7 MBP.

    I have used iTouchMIDI apps often with this setup too but not recently. These do not work with comp-to-comp any more as well.

    So there must be some upgrade that has added a security measure that prevents it. What a pain!

  10. #10

    When you go in the TouchOSC configuration page, you must see that there is a running OSCulator instance on your network. When you select it, it will fill the network configuration with the information about the running oscltr.
    I see my OSCulator instance, but when I select it nothing appears on Host and Outgoing port changes to -1.

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 3
    Last Post: 07-22-2010, 11:56 PM
  2. 2 x MAC's, 2 x VDMX, 1 Network, 1 TOUCH OSC /// POSSIBLE ?
    By lichtanlichtaus in forum Mobile Apps (iOS, Android)
    Replies: 1
    Last Post: 07-08-2010, 11:27 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts