No announcement yet.

Luminair Connection Issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • Luminair Connection Issue

    Hey Cam,

    I finally had a bit of time to go back to Luminair recently and thought I would play with the Wiimote. I opened everything I had saved (was using TouchOSC and had it working just fine) and now I'm having connection issues.

    I have my Event Type as OSC Routing and am using the pre-defined parameters I downloaded from the site in the value column. I'm getting a green indicator light in Osculator when using both the Wiimote and TouchOSC. Luminair is showing up as expected when selecting a Host in the Paraments menu and I have that radio button selected.

    Luminair has OSC Input enabled and listening on port 8000 (this is the same port that OSC is listening too). I've tried changing the port which Osculator has no trouble recognizing but Luminair is still unresponsive.

    Am I overlooking something extremely simple?

    Sorry for the trouble,

    Last edited by Kid Missleproof; 01-18-2012, 10:27 AM.

  • #2
    Hey K,

    The two applications do not need to be on the same port, each one can freely use its own port. (to understand this, I invite you to read the first chapter of the User's Manual, just click on the Help menu and choose User's Manual).

    Now, I would need to know exactly how things are configured in your document to know if it is compatible with Luminair. If you can please attach your oscd file to this thread (go in the "advanced" reply mode), so I can have a look. If there is anything wrong, I will try to explain you why.



    • #3
      Luminair File Attached

      Thanks again cam.
      Attached Files


      • #4

        After furthur troubleshooting, I believe there is a problem with Lion, iOS 5 and Bonjour. I'll let you know what I find.


        • #5
          Hey Kid!

          I'm sorry, I skipped your reply with the oscltr file.
          I just tried it and had no problem controlling Luminair with my iPhone (I am using Snow Leopard).
          What gave you the idea that Bonjour has problems with iOS 5 and Lion?



          • #6
            One thing I noticed was when I open the OSC Input screen in Luminair is, my iPad displays it's information without 'Bonjour' in front of it as it does in the screenshot in the manual. Other than that I looked online and there have been other reports of Lion having trouble with Bonjour and iOS 5

            I did just use the 'Remote' application which also operates with Bonjour and acessed my iTunes from from iPhone and my iPad... so I'm not sure. I have turned off my firewall and little snitch so all of my communication should be fine. I will bring my laptop with Snow Leopard tomorrow and see if I can connect. I'll let you know.


            • #7
              Tried it with Snow Leopard and I'm having the same issue. That means it has to be a network problem which is odd since I haven't changed anything hardware wise. I'll let you know if I find a solution.


              • #8
                Rebooted everything and it still won't work. It seems like there is a problem from Osculator to Luminair on the iPad. Cam could you send me a screen shot of your OSC options screen in Luminair? The only thing I can see that might be wrong is it does not say Bonjour before the iPad name (Luminair):8000.


                • #9
                  Hi Kid,

                  Here are a detailed steps on how I do to configure OSCulator and Luminair.

                  On my Mac running Lion, I launch OSCulator with an empty document.
                  Then I launch Luminair v1.4.4 (401) on my iPad.

                  In the Parameters Window, I automatically get this:
                  luminair 1.png
                  No configuration was needed in OSCulator.

                  In Luminair, I don't remember exactly what I did, but when I tap on the settings button, go to Settings, then scroll to the end of the pop-up window, there is the OSC Input item. It is Enabled and the Input Port is 8000 (any port number should do as long as it is higher than 1024 and under 65536).

                  Then, I import the Luminair OSC Routings, in the current document. In the Samples Library, I navigate to Mobile-iOS/Luminair for iPad and select the file Luminair OSC Dictionary.

                  Next, I take my iPhone and open the application TouchOSC. The OSCulator Window now looks like this:

                  luminair 2.png
                  In TouchOSC's Network Settings, I choose the host that corresponds to my Mac (not my iPad).
                  Finally, I assign some Luminair actions to TouchOSC's controls:

                  luminair 3.png

                  Note: As you may have noticed in the second picture, the default target is still the iPad (Balivernes). If the default target has ever changed to the iPhone (Rubicon), I would have to change the radio button to select the iPad because the routings used to send messages to Luminair are configured with the default target.

                  Now, if you don't want to ever have to change this setting, simply set your iPhone as the default target, but change the target of all the routings for Luminair. This can be done in two mouse clicks: first set your iPhone as the default target, then select all OSC routings for Luminair and change their target to the target number to which your iPad is connected. (in my case Baliverne is in slot one) as you can see in this screenshot.

                  luminair 4.png

                  Last edited by camille; 01-31-2012, 10:15 AM.


                  • #10
                    Thanks for the reply cam. Those are the settings I had before (albeit a different boot order) and there is still no communication between Osculator and Luminair. Perhaps I'll try to contact luminair staff and see if they have any ideas.



                    • #11

                      I disconnected from the sACN network and created a local network from my laptop and everything with oscillator worked fine. I'll try switching out the nodes and see if I can get everything working.


                      • #12
                        What is an sACN network?


                        • #13
                          You can either connect to DMX via ArtNet or streaming ACN in Luminair. ACN only supports DMX Output, not input.

                          The basic setup is a wireless router (doesn't need to be connected to the internet) that plugs into a ACN Gateway via Ethernet. Then out via DMX to the lighting unit. The iPad locks on to the same wireless network and I am currently able to control the fixture with no problem via Luminair and my iPad.

                          When I put my computer and iPhone on the same network though, I am able to communicate with Osculator via the iPhone but Osculator doesn't seem to be able to communicate with the iPad and Luminair from there. Due to the recent discovery that I can control Luminair via Osculator and my iPhone just fine when my computer outputs a wifi network, there is probably something wrong with the wireless router or Gateway. I'll investigate more today and let you know.



                          • #14
                            After much trial and error I eventually got it to work by resetting the router to factory default settings, then editing the connection settings from scratch.


                            • #15
                              So that was it? I sympathize with you.
                              Just out of curiosity, did your router require specific configuration?
                              Or it was only a matter of corrupted settings?