No announcement yet.

Fader on rotary for ableton live / only min and max

  • Filter
  • Time
  • Show
Clear All
new posts

  • Fader on rotary for ableton live / only min and max


    I'm beggining with OSC.

    I just want to make basic control with faders and rotary, but they only move from min to max.
    On osc editor I changed the value range from 0 to 127
    and on osculator
    message event type value channel
    /2/fader4 midicc 24 16
    /2/fader4/z midicc 25 16

    I think it's just a little error....

  • #2
    Hi Boxyd!

    Just change them back to 0.0 1.0. OSCulator automatically scales OSC float numbers for MIDI values.



    • #3
      Hi camille.

      Sorry but it still the same problem.




      • #4
        So simple....

        Hi Camille...

        Finaly I found the answer.
        I don't need to to assign all the /x/faderX (or rotaryx or toogglex, etc)/z...
        If I let all the " ..../" without any assign, it works !
        Is it normal ?

        And now I have another question ? Is it possible that faders or rotary learn the position of the cursor...
        I have a live set with some effetc, and I want to begin by the right position, and after move from this one. Is that clear, or my english is too bad ?



        • #5
          Salut Antoine,

          The /z part of the message is indicating a touch on the control. When a control is touched, it will send its value (for example through the /1/fader1 message) and also anoher message /1/fader1/z with a value of 1.0. When released the /1/fader1/z message has a value of 0.0.

          Advice: try to configure only what is needed, start with a small configuration and increment over it to make it larger, again configuring only the relevant bits.

          About your second question:
          I don't know what software you are controlling with OSCulator, but there is a small trick with Ableton Live I've learned recently: If you enable MIDI mapping mode (Command-M), and disable it again (Command-M again), it will re-send all last known values. So if TouchOSC is not in sync with the values in Live, doing this will sync the values again so you can start from where you left your work.



          • #6
            Salut salut

            Do you mean that ".../z" message needs to be assign with a value of midi event or not ??
            If I don't assign them, is there any risque or conflict

            Yes I work with Ableton Live. Thanks for the tips but it didn't want to make moove my faders and rotarys in the right position...
            I'll try again ...



            • #7
              hello Camille...

              The "Command-M" tips works with "xy"...
              But doesn't work with faders and rotary. Do you have an idea to make it work ?



              • #8
                It does, but a small bug slipped into the latest release.
                So, update to, and then delete every message starting with /midi in the list.
                It will work as expected.


                • #9
                  hi camille...
                  Excuse these lot of little messages....
                  I realise that the problem is one particular point...
                  When I move xy on ipad it also moves on Live, when I move it from Live, it also move on the ipad.
                  But with faders, rotarys, and toogle buttons, it moves from ipad to Live, but not from Live to Ipad ?
                  What do I forgot to do ?

                  Thanks !


                  • #10
                    Antoine, this is the same problem.
                    Please update to the latest version and delete all messages starting with /midi.


                    • #11
                      Thanks, I haven't see the previous message...
                      I did it and it works ! Perfect...
                      Just a last question...
                      After deleting all messages witch beggin with /midi, they come again when I use touch osc or live.
                      Is it ok ?

                      Thanks a lot...
                      This is already a revolution in my way to create and prepare concert and theater session !


                      • #12
                        After deleting all messages witch beggin with /midi, they come again when I use touch osc or live.
                        Is it ok ?
                        Absolutely, OSCulator translates OSC to MIDI (you specify what to do) and tries to automatically translate MIDI to OSC.
                        If you delete the messages starting with /midi, OSCulator will re-create the settings. I asked you to do this because the previous version was using an invalid configuration for these messages, therefore you had to delete them.

                        Bon courage Antoine!