No announcement yet.

Wacom PTH-451 Intuos Pro S (Pen & Touch Tablet, Small) - Driver Problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Wacom PTH-451 Intuos Pro S (Pen & Touch Tablet, Small) - Driver Problem

    Hi, great software you have created!
    I will sure buy it and support it.

    However the last supported driver for Wacom tablets is "Driver 6.3.18-4"
    which is from 2016 year.

    I just bought Wacom PTH-451 Intuos Pro S (Pen & Touch Tablet, Small)
    I work on Mac OS X Sierra 10.12.6

    The latest Wacom driver version 6.3.27-2 doesn't work with OSCulator 3.1.2 unfortunately.

    When I press caps lock and move and tilt this is all what I got.

    OSCulator 1.png

    The activity square light up on the moment of first contact of the pen with surface
    and then when I taking pen away..

    I tried "Driver 6.3.18-4" and OSCulator seems work fine,
    but I am afraid that this version of driver might be not fully compatible with my tablet..
    and I'm planing to use this tablet with many applications not only OSCulator,
    so using old driver from 2016 is not ideal situation..

    From some posts on the forum I understand that it's hard to make compatibility
    with every new version of Wacoms driver, but maybe would be possible to manage
    and have OSCulator compatible with at least one version of Wacom driver per year.

    That would keep Wacom tablets up to date with new versions of operating systems
    or ensure Wacom tablet compatibility with other applications.

    (p.s. not sure if they should or not working, but touch functions are not recognizable with either version of wacom driver)

    Here is screenshot of this tablet working with OSCulator using Driver 6.3.18-4

    Screen Shot 2018-01-28 at 13.12.18.png

    This is pretty impressive! Love it!
    I tried already pen pressure, x and y.
    *Pen/Eraser Button 1 and 2 are numbered as 2 and 3.
    Button 1 showing up automatically, but it could be an error or related to other kind of pen.

  • #2
    Hi nicecat,

    Thanks for your message.

    As explained in this thread, it's not really OSCulator not being compatible with Wacom tablets, but the opposite. OSCulator used the same driver code for years, and Wacom was exceptionally good at keeping their drivers backward compatible.

    Unfortunately this changed when macOS El Capitan introduced complications with how devices are allowed to control user input. It's got worse in macOS Sierra. I am still waiting for Wacom to fix their driver, but I guess they have more important applications to fix before us...

    If nothing is done by end of February I will investigate an alternate way of accessing Wacom drivers.



    • #3
      I see. Thank you for the explanation.


      • #4
        Hey nicecat,

        I just wanted to follow up on the driver issue.
        I'm still looking for a solution.

        In the meantime you can use the latests driver with OSCulator, but the "mouse locking" feature is what is causing the bug in the Wacom drivers. You can workaround this by choosing "No mouse locking" in OSCulator parameters (see screenshot).

        no mouse locking.png

        The problem indeed is that whenever you use the tablet pointer, is activates the UI elements which is not really something desired. What you can do is launch a dummy app like TextEdit and set it full-screen so tablet events don't matter. Better, you can use a drawing app and have fun drawing and controlling something at the same time.



        • #5
          I also have a wacom tablet, but it works well with OSCulator, no driver issues.