No announcement yet.

OSCulator not responding to SpaceNavigator unless app is in foreground (Monterey)

  • Filter
  • Time
  • Show
Clear All
new posts

  • OSCulator not responding to SpaceNavigator unless app is in foreground (Monterey)

    I just got a new Mac Studio Ultra (Monterey) and I'm in the process of porting everything over from my Mac Pro 5,1 (Mojave).

    I use OSCulator to translate SpaceNavigator controller movements into outgoing MIDI CC messages. Everything works fine as long as OSCulator is in the foreground. But as soon as the application loses focus, it stops receiving (and therefore, sending) messages.

    Any idea what I'm doing wrong?

  • #2
    Does anyone monitor this forum?


    • #3
      Hi Karl,

      Could you please tell what version of the 3dconnexion driver is installed on your computer?
      The problem is most likely a bug in the driver.



      • #4
        Hi Camille,

        Thanks for replying. I'm using the latest driver:

        3DxWare 10
        3DxMacCore version (285)
        3DxWare version 10.7.2 (3454)

        SpaceMouse Wireless
        Firmware 4.38
        You do not have permission to view this gallery.
        This gallery has 1 photos.


        • #5
          Hi Karl,

          I just upgraded to the latest driver version and could not replicate this behavior with default settings.

          I know the 3dconnexion driver is able to activate the device based on frontmost applications, could it be that you have configured yours like this? I would recommend trying to reset the driver to its defaults (in the 3dconnexion pane, go to tools tab, click "Use Defaults").

          I have been able to replicate the unwanted behavior by:
          - adding OSCulator as a new application profile
          - switching back to the "Any Application" profile
          - setting all Axes mapping to "Disabled" (but leave 3D Mouse for the "OSCulator" profile).
          This settings prevents routing the SpaceNavigator Axes when OSCulator is not frontmost.

          Clicking "Use Defaults" enabled me to restore the normal behavior.